Change The default ports

My YunoHost server

Hardware: VM
YunoHost version: 11.0.10.2
I have access to my server : direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Hi,

how can i change ports 80 and 443 to another ports?

thanks.

You cannot.

(Without context, I feel like we are in a https://xyproblem.info/ situation)

1 Like

hey thanks for your reply
i didn’t got you much about without “context”

i want to change the admin panel and the client all to another port is that possible at all in yunohost?

these ports are used to be on my main server which is apache with 100’s of scripts, i gave up of using the default ports and using a custom instead, cause i didn’t find a way to change them,
once i changed the settings on nginx i got some issues so i revert them back,
443 also is in use on my DoH server i cant use it cause its in use by yunohost,

i think you guys have to do something about it, at least these two specific ports to my opinion need to be under control,

just for an admin panel and client its a little bit waste for users like me who use yunohost for synapse and email which is the most important scripts / servers to me,

i understand also i am going to get troubles with cerbot or whatever is use in yunohost,

also i do manually renewing my private letsencrypt certificates every 3 months, pointing temporarily the ports back to my machine to accept acme validation, so i was thinking if i could change the client ports, compile a webview for it with the defined ports for android and electron for desktop that should be enough,

so no chance?

No, that’s theoretically possible but in practice changing the https port is a mess both from the user and technical point of view. There are too many implicit redirection to https://domain.tld everywhere. Also port 80 needs to be exposed for Lets Encrypt to work.

Maybe but clearly we wont : this is too much of a super corner case, and it’s just not worth the time and energy considering the shitload of other more important projects in the todo

2 Likes

sure sure i understand all these issues, thank you both.

@tituspijean
@Aleks

Guys now i am in a huge trouble, for several hours i did try to update my ip, used update force but it didn’t help,

finally I discovered it need port 53 to update my ip?
I use port 53 for my pihole server,
I am using my own pihole server not the yunohost one, the reason for that is when i tried to use the “docker” based pihole on yunohost it didnt work well, its an old version and doesn’t shows some details on the gadgets,

why its happening in the past i was able to update my ip without port 53,
i almost sure 99% i did never open port 53 in the past and the ip were updated successfully,
do you have any suggestion?
there is anything i can do on my end?
change some script / code?

i have no idea why you think you need port 53, nor “where” you want to update your ip (is it some .nohost.me stuff ?) nor if you mean incoming or outgoing traffic …

1 Like

my domain is eynh.ynh.fr
my domain wasn’t reachable till I moved port 53 from pihole to yunohost on the port forwarding,

once i did so, it tool exactly 10 seconds till it did update my ip, and the domain was reachable, i did never seen such fast dns update,
there were many people lastly on the forum who did complaint about DNS update i am starting to suspect they had the same issue,

@Aleks

this is my firewall:

i dont have anything installed only synapse, nothing else.
i dont really understand why the server need port 53 its not weird?

The firewall and port forwarding you are talking about should have nothing to do with the dyndns update. It doesn’t use incoming traffic on port 53. My understanding is that the only interference could be about OUTGOING traffic being filtered on port 53, which YunoHost doesn’t configure and is unrelated to the screenshot you’re showing. So maybe something about your pihole install interfering with port 53 ougoing traffic …

The first thing i have done i did changed my machine DNS to cloudflare so i will be sure pihole will not filter anything necessary,

i did stop all of the firewalls completely, include malwarebytes, HIPS, IDS, and any security program might will interfere with yunohost,

tried to update every several minutes, with update force, was waiting and waiting,

finally, i was thinking like i told myself wait why port 53 is on the firewall list, i will try to open it for yunohost once i did this, i swear it took exactly about 6 or 8 seconds for the domain to be reachable, there were my domain at background of my screen trying to load so i saw it online once i did update it being loaded, i was very surprised, what’s the connection between inbound permission to the DNS update, that’s what happening,

is there anything i can do to provide a log or anything that can indicate something?

and also why port 53 is appear on the firewall list? what is it for i have synapse installed only?

chrome_klPDslFlNO

Port 53 is in the firewall list because some people want to use DNSmasq as home DNS resolver in home hosting context, yet it is not UPnP-enabled by default because you don’t want to expose it worldwide by default.

I’ve seen Yunohost’s dyndns work in many context without port 53 being forwarded, and this make no sense that there would be any relation between those, so not buying it

1 Like

i cant renew my ip at the moment cause my father is watching (using the net)
later i will renew the ip to another one and test, i am starting to think that might a coincidence, though i hardly believe it is, i have to test to make sure, I do networking over 20 years and i do agree there is no relations between a local open port to a remote DNS server,
i am just telling what i saw,

there are two options

  1. it was a coincidence, that took the dyndns server to update my ip for more than several hours and at the moment’s i did open port 53 it being updated and i thought its because of that,

  2. the previous pihole has did changed something on the server and didn’t revert it back to normal after the uninstallation,

i will test it later and will update you what’s happening for whatever the situation will be, if its a coincidence i will inform anyway,

@Aleks

i found the problem,

i don’t know what’s happening i never seen anything like that before,
as long port 53 pointed to my pihole server i cant reach yunohost server by the domain, only by my public ip, it doesn’t matter where port 53 pointed to just not to pihole,
no matter what i do, disabled filter and unticked all options as dnsec and others, + permitted any origin

now when i changed the machine dns to cloudflare i can reach yunohost, i have done this before and it didn’t help, now its working,
maybe some cache still used pihole,

pihole blocking me from reaching my own domain, i don’t know what to think,
i am going to install a server with apache just for to test if it does the same issue with another server than yunohost,

bro you were right when you said something with pihole, is just all what i have done did confuses me cause i did tried so many things i probably don’t remember the order i have done them,
what i don’t understand is why when i took out port 53 from pihole its suddenly worked, so its means the ip were updated and at that moment the browser were able to reach the domain,

its the craziest thing i ever seen no joke,

anyway all is fine the server sorry for bothers you for nothing,
if i will figure out what’s going on i will inform just for general knowledge maybe ever someone will have this issue

@Aleks
update:
that doesn’t happening with my private domain only with yunohost domain,
i have no clue and no ideas anymore,