Certificate renewing for domain.com failed

I am unable to renew the certificate. Here is the log:

email: false
force: true
no_checks: false
staging: false
ended_at: 2021-02-26 10:51:27.257110
error: Certificate renewing for maindomain.tld failed !
interface: true
operation: letsencrypt_cert_renew
- - domain
- maindomain.tld
started_at: 2021-02-26 10:51:24.702787
success: false


2021-02-26 05:51:24,734: DEBUG - Making sure tmp folders exists...
2021-02-26 05:51:24,735: DEBUG - Reusing IPv4 from cache: xx.xx.xx.xx
2021-02-26 05:51:24,735: DEBUG - Reusing IPv6 from cache: None
2021-02-26 05:51:24,736: DEBUG - Prepare key and certificate signing request (CSR) for maindomain.tld...
2021-02-26 05:51:24,804: WARNING - Subdomain 'xmpp-upload.maindomain.tld' does not resolve to the same IP address as 'maindomain.tld'. Some features will not be available until you fix this and regenerate the certificate.
2021-02-26 05:51:24,811: DEBUG - Saving to /tmp/acme-challenge-private/maindomain.tld.csr.
2021-02-26 05:51:24,811: DEBUG - Now using ACME Tiny to sign the certificate...
2021-02-26 05:51:24,812: INFO - Parsing account key...
2021-02-26 05:51:24,823: INFO - Parsing CSR...
2021-02-26 05:51:24,835: INFO - Found domains: maindomain.tld
2021-02-26 05:51:24,836: INFO - Getting directory...
2021-02-26 05:51:25,172: INFO - Directory found!
2021-02-26 05:51:25,173: INFO - Registering account...
2021-02-26 05:51:25,884: INFO - Already registered!
2021-02-26 05:51:25,885: INFO - Creating new order...
2021-02-26 05:51:26,536: INFO - Order created!
2021-02-26 05:51:27,222: INFO - Verifying maindomain.tld...
2021-02-26 05:51:27,255: ERROR - Wrote file to /tmp/acme-challenge-public/uUPf26qWA07rcJs2klWeKu8IPMDhtxHQmzv__-dxxwE, but couldn't download http://maindomain.tld/.well-known/acme-challenge/uUPf26qWA07rcJs2klWeKu8IPMDhtxHQmzv__-dxxwE: 'ascii' codec can't encode character u'\ufeff' in position 0: ordinal not in range(128)
2021-02-26 05:51:27,256: ERROR - Certificate renewing for maindomain.tld failed !

I’m using yunohost domain cert-renew --debug --no-checks. Log:

60531 ERROR Certificate renewing for maindomain.tld failed !
Please consider checking the 'DNS records' (basic) and 'Web' categories of the diagnosis to check for possible issues that may prevent installing a Let's Encrypt certificate on domain maindomain.tld.
60532 INFO The operation 'Renew 'maindomain.tld' Let's Encrypt certificate' could not be completed. Please share the full log of this operation using the command 'yunohost log display 20210226-123043-letsencrypt_cert_renew-maindomain.tld --share' to get help
60633 ERROR Traceback (most recent call last):
  File "/usr/lib/moulinette/yunohost/certificate.py", line 386, in certificate_renew
    _fetch_and_enable_new_certificate(domain, staging, no_checks=no_checks)
  File "/usr/lib/moulinette/yunohost/certificate.py", line 580, in _fetch_and_enable_new_certificate
    raise YunohostError('certmanager_certificate_fetching_or_enabling_failed', domain=domain)
YunohostError: Trying to use the new certificate for bigdata8.ddns.net did not work...

60634 ERROR Trying to use the new certificate for maindomain.tld did not work...
60635 DEBUG action [32590.1] executed in 60.448s
60635 DEBUG lock has been released

I ran the command yunohost domain cert-renew --no-checks again:

Info: No certificate needs to be renewed.

Everything works now …

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.