Certificate renew : Error submitting challenges

My YunoHost server

Hardware: Raspberry Pi 4 at home
YunoHost version: 11.2.5
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue


I get an error when attempting to renew my certificate (subdomain.nohost.me). The domain has no ipv6, but is available on ipv4. I can reach it from outside and I use it every day. The log looks like this (full log on Yunopaste)

2023-10-24 07:17:59,579: INFO - Order created!
2023-10-24 07:18:16,679: INFO - Verifying maindomain.tld...
2023-10-24 07:22:38,102: ERROR - Error submitting challenges: maindomain.tld:
Response Code: None
Response: Remote end closed connection without response
2023-10-24 07:22:38,128: ERROR - Certificate renewing for maindomain.tld failed!

I also have tried yunohost domain cert-renew --force --no-checks but I get the same error. It displays additionnal details

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/yunohost/certificate.py", line 390, in certificate_renew
    _fetch_and_enable_new_certificate(domain, no_checks=no_checks)
  File "/usr/lib/python3/dist-packages/yunohost/certificate.py", line 515, in _fetch_and_enable_new_certificate
    raise YunohostError("certmanager_cert_signing_failed")
yunohost.utils.error.YunohostError: Could not sign the new certificate

What should I check now ? Thanks for your help.

It looks like you used --no-checks despite possible issues found by the diagnosis, so I would first try to read what the diagnosis is telling you about this domain ?


  • Everything is fine for internet connectivity, but no ipv6
  • The domain is not accessible from outside.

I guess this is the problem. But I don’t understand this part. Because I can access my domain from outside. I have checked again right now using Tor.

I close this topic and I open another one for finding out why the server is said not accessible.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.