Castopod Admin panel not reachable after upgrade

My YunoHost server

Hardware: Raspberry Pi 3B
YunoHost version: 4.3.6.3
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello and thanks in advance for any help provided. I have updated Castopod from 1.0.0-96-ynh1 to 1.0.0-98-ynh2. The upgrade appears to process successfully, but after the upgrade, when I log into the cp-admin page, the “Whoops” page comes up and I am unable to access my podcasts that have been posted.

Same thing for me, all three of my podcasts.

I made an issue for this.

Ok @DDRrayray2012 , I got back to it by going to https://(yourdomain.com)//cp-admin and that brought my back to the Auth page where I could log back in and everything went back to normal.

Give it a go and see if it works for you.

Just tried this method. It allowed me to log in, but would not load anything after that. Just brings up this image.
Untitled

Try clearing your cache or going to https://{whatever.yourdomain.tld}/cp-admin in an incognito/private window

I just tried this in both safari and chrome and I’m still getting the “Whoops” screen after logging in on the cp-admin page. Would having more than 1 show on a castopod instance be affecting this?

No, the show does not matter as the URL is independent of the show. Can you share the URL of your Castopod instance on the linked GitHub issue?

sure. It should be there now. I did apply the latest 1.0.0-99~ynh1 version.

it still has the same issue with the 1.0.0-99-ynh1 version as well.

Having the same problem:

after upgrading my instance only shows the whoops hit a snag image, for admin and for the public facing site for my podcast.

I can login to the admin but only see whoops hit a snag. I also had the problem when upgrading from 1.0.0-96-ynh1 to 1.0.0-98-ynh2 and from 1.0.0-98-ynh2 to 1.0.0-99~ynh1. Using Yunohost version 4.3.6.3 (stable) on a VPS.

I can restore back to 1.0.0-96-ynh1 but my latest episode was not uploaded for that back up, and my latest episode still seems to be accessible via RSS for podcast apps and such.