Cant't install Mastodon app

Hardware: VPS bought online
YunoHost version: (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version:

Tried to install Mastodon app via web and via cli. The process was unsuccessful.

Via cli:

  1. sudo yunohost app install GitHub - YunoHost-Apps/mastodon_ynh: Free, open-source social network for YunoHost
  2. Info: Installing Ruby-3.2.2 (very looong but passed)
  3. in the end: Error: The operation ‘Install the ‘mastodon’ app’ could not be completed.

This is the log:


It may look like a temporary network issue, but if you tried with both webadmin and CLI, that’s twice in a row. I saw some comments on IPv6 connection being unreliable or SSL version. Let’s investigate, what’s the output of the following commands?

curl -4
curl -6
openssl s_client -connect

(exit that last command with CTRL+C)

curl -6
via cli on YH instance blinking cursor
via cli on my pc: curl: (7) Couldn’t connect to server

openssl s_client -connect
via cli on YH instance blinking cursor
via cli on my pc:

openssl s_client -connect 
depth=2 OU = GlobalSign Root CA - R3, O = GlobalSign, CN = GlobalSign
verify return:1
depth=1 C = BE, O = GlobalSign nv-sa, CN = GlobalSign Atlas R3 DV TLS CA 2023 Q3
verify return:1
depth=0 CN =
verify return:1
etc. etc.

IPV6 is not active on my VPS

So uh it doesn’t display anything ?

had to change ipv6 configuration

commented ipv6 related records
then openssl s_client -connect
now trying to install again

The problem seems to be solved. Was an ipv6 connectivity issue but I had to deactivate it on my instance.

The strange thing is that

openssl s_client -connect

tried to connect only via ipv6

1 Like




This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.