Can't upgrade PeerTube?

Hello everybody…

I’ve just tried to upgrade Peertube, from5.2.1~ynh1 to 6.0.2~ynh3
I’ve already update YNH to the last version.

My machine is a GT110i, with quad Xeon E3-1225, 4TB SSD … everything is up to date.

Here’s the log:

If anyone got an idea… thanks !!

Sounds like this is an old install and “admin” was not defined at the time

You may set the setting manually with yunohost app setting peertube admin -v <some_admin_username> with <some_admin_username> being an actual yunohost user on your system

weird… I always update everytime a new version is out… meaning maybe there was a bug somewhere that blocks the update to show up ?!

and I’m pretty sure there was an admin, too… but anyway, I’ve just tried what you wrote and it’s done !! so, thanks (again) !!

I’m not sure.

As reported on Matrix, I gathered this feedback for the exact same issue :

ynh_user_get_info --username=$admin --key="mail" won’t work if admin user doesn’t exist.
Is that expected ?
Because in peertube upgrade script it’s used.
And funnier : for one user, yunohost user info admin gives a result. But not ynh_user_get_info --username=$admin --key="mail"

Or maybe you mean the “admin” account in Peertube ?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.