Can't upgrade apps anymore

,

Hi all !

My YunoHost server

Hardware: VPS bought online (proxmox + vm ynh_server)
YunoHost version:

root@krashboyz:~# yunohost -v
yunohost: 
  repo: stable
  version: 4.3.6.3
yunohost-admin: 
  repo: testing
  version: 4.3.4.1
moulinette: 
  repo: stable
  version: 4.3.3.1
ssowat: 
  repo: stable
  version: 4.3.3.1

I have access to my server :
Through SSH : YES
Through the webadmin : YES

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? :
If yes, please explain:
added the fallback app, then removed it few days after; i tried to reinstall fallback after the bug incomming, but it doesn’t fix it. (it is not really a tweak :confused: )

Description of my issue

i can’t upgrade my apps anymore via cli and webadmin.

command result error log
yunohost tools update → works fine :white_check_mark:
yunohost tools upgrade system → works fine :white_check_mark:
yunohost tools upgrade apps → is broken :x: → error log: https://paste.yunohost.org/raw/oterigavul
yunohost app upgrade wikijs or any other installed app → is broken :x: → error log: https://paste.yunohost.org/raw/ujecuwobuv

i searched a bit everywhere, tried to force to upgrade moulinette without any better result,
i’m a bit locked and need your kindless help.

i don’t see what i could done wrong,
my server is old old old, perhaps some old stuff somewhere ?

tell me if you need any more details.

thx for your help (i understand french and english)

isAAAc
(ps: the ‘optional tags’ is broken when creating a post here, getting an 500 error :wink: )


EDIT: github issue is open there too: can't make any app upgrade after removing fallback app · Issue #30 · YunoHost-Apps/fallback_ynh · GitHub

Seems to be some problems with backups before upgrades.

You can try something like that if you already have some backup :
sudo yunohost app upgrade wikijs --no-safety-backup

It is more a workaround than a real solution…

thx for your help @rungeard :wink:

“clean” fix in the issue

i rm all backups

I wonder why I didn’t think of that :stuck_out_tongue:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.