Can't upgrade a couple of different packages after changing and reverting sources.list

Hi all,
I’ve been using YUNoHost for a few years and very happily - after the first day :slight_smile:
I’d been hosting from scratch for decades and had my own, long checklists of Things To Do. I had to reinstall like 4-5 times that first experience, because I just didn’t understand that I had to keep my grubby meathooks off everything ! :slight_smile: But, after I finally got that memo, things have been fine - and fun even. It gets quite boring creating new users and new databases and nginx entries, only to find out that you really don’t like shiny new X application after all. Yunohost makes playing around so painless!
Also, postfix. After the horrors of Sendmail and friends years ago, postfix was a blessing, but I’ve gotten rusty and it takes me forever these days. Yunohost makes it a snap - and smiple aliases too :wink:

My YunoHost server

Matériel: VPS acheté en ligne. VPS from Contabo using contabo hosted debian repos
Version de YunoHost: (stable).
J’ai accès à mon serveur : En - SSH with private key only and non-standard port
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifications particulières sur votre instance ? : oui
Si oui, expliquer:
Yes, as described below, I changed my sources list in an attempt to correct an expired key problem that prevented upgrading. When that failed, instead of reverting, I got the new key and upgraded manually, since I was in the shell already… (mistake part). I then had problems upgrading a couple of packages. Finally realizing I’d screwed up by a) doing things manually and b) making batch changes, I reverted to the original sources list, but there is one package I can’t upgrade: RoundCube.

Description of my issue

So anyhow, a few weeks ago I couldn’t upgrade the system - it kept failing on an expired key. I thought it had something to do with contabo’s own repos, so I changed my source list to debian’s own.
Same problem.
—> 2nd mistake here <-------
I looked into it more and found it was a common problem and got a new key:
apt-key adv --fetch-keys ‘
Having the same problem, I should have instead reverted to my original sources.list, but I continued and had now done batch changes…
Glitchsoc failed to upgrade and also Roundcube.
I did revert to the original sources.list and performed an ‘apt update’ successfully. I guess it liked the same key.
Some things upgraded fine: Peertube, TTRSS, My_WebApp, Wordpress and Syncthing.
The same two fail though.
error log:
error log:
I know I’m the author of my own misfortune here - I forgot to keep my mitts off the underlying system :frowning:
Glitch is now hosed and a 502 - fair enough. It’s experimental and discardable, but I’d like to upgrade RoundCube at some point.
I think I have confused ‘Composer’ with my meddling, but I have zero experience with things like chef, puppet or composer. Also, I may be wrong about that! :slight_smile:

Thanks for reading this far! If anyone is familiar and has time, I’d appreciate it. Tbird and evolution both continue fine, of course. For that matter, RoundCube still works too. I just can’t upgrade it, so no big rush.
– gemlog

Sorry, you have a mistake, but the 2 links are for Glitchsoc.
For roundcube there is an issue not yet resolved for now

Sorry, you have a mistake, but the 2 links are for Glitchsoc.
Thank you, I fixed it. different URLs same content - I guess I tried a couple of different options, before giving up

For roundcube there is an issue not yet resolved for now
Aha! Nothing like having more than one problem at a time eh? :slight_smile:
Thank you so much. I’ll just ignore it for as long as possible, or until there is a fix.
Thank you very much for replying me!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.