Can't login at hosting computer server

My YunoHost server

**Hardware:
Old gaming computer. nividia 970 display card, 500gig crucial ssd, mbord: gigabyte GA-X58A-UD3R with 16gig of mem

**YunoHost version:
yunohost-bullseye-11.0.9-amd64-stable run from usb that was made using balenaEtcher-Portable-1.18.11
HDD was formatted using gparted-live-1.5.0-6-amd64

I have access to my server
direct access via keyboard / screen

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ?
no

Description of my issue

This is acually two problems and I know the issue is: PBKC (problem between keyboard and chair) :slight_smile:

I havent touched the server in almost a year and when I booted it up I get the error :
Local IP: (no ip detected)

So, I tried to login at the server using bouse and keyboard. I saved the password to a document. I’m pretty sure I’m no adding the right ending to the username and or password. Real newby here sorry …

Upon bootup I see:

bob login:

my password is brown

so do I use

  1. bob login:brown

or
2. bob login: bob@brown

I then see password:and I type
password: uncertainme

I get
incorrect login
bob.nohost.me login:

Hoping someone can set me straight

Best regards,

I

Here are some error messages

:fr: Modèle de message (français)

La catégorie “support” est destinée à l’aide et au dépannage lié à l’installation et utilisation de YunoHost et de ses applications. Elle n’est pas destinée à de l’assistance généraliste pour l’administration système, réseau, ou pour les cas particuliers qui vont au dela de ce que propose le projet. Si vous souhaitez discuter de cas d’usage avancés, merci d’utiliser la catégorie “Advanced Use Case”.

Avant de poster, merci de :

Mon serveur YunoHost

Matériel: VPS acheté en ligne / Vieil ordinateur / Raspberry Pi (préciser version, de 0 à 4) à la maison / Brique Internet avec VPN / Autre carte ARM / …
Version de YunoHost: x.x.x
J’ai accès à mon serveur : En SSH | Par la webadmin | En direct avec un clavier/écran | …
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifications particulières sur votre instance ? : non / oui
Si oui, expliquer:

Description du problème

Pour obtenir de l’aide efficacement, expliquez qu’est-ce que vous cherchez à faire, dans quel contexte, qu’est-ce que vous avez essayé, et les messages d’erreurs / logs détaillés si possible.

Évitez de dire que quelque chose ne “marche pas” ou ne “fais rien” … expliquez ce qui se passe vraiment et comment vous l’interprétez !

NB: nous préférons que vous partagiez les logs complets en cliquant sur les boutons verts “Partager les logs avec YunoPaste”.
Vous pouvez aussi les copier dans paste.yunohost.org ou inclure directement ces messages en utilisant les “backticks” (accent grave) comme ceci :

Voici des messages d'erreurs

You need to pass your username first, whatever it might be, then your password when prompted for password.
If you have your credentials stored in some password manager both username and password should be there and, if that’s an admin user, you should be able to log in locally to see what the issue with networking may be.

Hi uncertain,

So, you actually have the command line login in front of you, not the web page, correct?

In that case, ‘bob’ would be the name of your Yunohost. It would look like:

bob login: unknown (your Yunohost admin user)
password:  (stays empty while typing)

Hi @orhyej2 and @wbk

Thankyou for your assistance. As happens in computerland, I turned it on this morning and it worked. I was able to logon with the username and password that was rejected at the server console.

I would still like to workout what I’m doing that is wrong if you are still willing? Here is the answer to @wbk questions
[/quote]

So, you actually have the command line login in front of you, not the web page, correct?

Yes

In that case, ‘bob’ would be the name of your Yunohost. It would look like:

Here is an annotated picture of what I am seeing and doing. Hope this helps’

Question: I know from my reading that the no ip at boot is a known bug. The solution is to apply a script that keeps the network card active? Can I apply this scrept / edit from the web interface? Are there clear step by step instructions on how to do this?

Many thanks,

I

Wohoo!

In that case, do you log in here (user portal),

image

or here (admin portal)?

image

Not all users that can log in as a user, also can log in as admin. In general, only the users that can log in as admin, can log in on the command line.

So if ‘bob’ can log in at the user portal, but not at the admin portal, the login will be rejected when you try to log in via screen and key board.

I’d be interested as well! I think it sometimes happens to me, but not often enough to be sure it actually happened or that I misconfigured something.

Hi @wbk ,

yes, that is great news! Thank you for your assistance!
I can login on both portals now but I am using the admin one. The pc seems to be rebooting reliably with network.

My next challenge seems to be updating the system. Each time I do “update all” it kicks me out and when I log back in nothing has changed. I have attached the log file below.

Note: Should I start a new topic for this?

args:
target: system
ended_at: 2024-04-10 00:23:03.904638
error: null
interface: api
operation: tools_upgrade
parent: null
related_to:
started_at: 2024-04-10 00:23:00.863448
success: true
yunohost_version: 11.2.4

============

2024-04-10 10:23:00,872: INFO - Upgrading system packages
2024-04-10 10:23:00,874: DEBUG - Running apt command :
DEBIAN_FRONTEND=noninteractive YUNOHOST_API_RESTART_WILL_BE_HANDLED_BY_YUNOHOST=yes APT_LISTCHANGES_FRONTEND=none apt-get --fix-broken --show-upgraded --assume-yes --quiet -o=Dpkg::Use-Pty=0 -o Dpkg::Options::=“–force-confold” -o Dpkg::Options::=“–force-confmiss” -o Dpkg::Options::=“–force-confdef” dist-upgrade
2024-04-10 10:23:00,934: INFO - + Reading package lists…
2024-04-10 10:23:01,114: INFO - + Building dependency tree…
2024-04-10 10:23:01,115: INFO - + Reading state information…
2024-04-10 10:23:01,283: INFO - + Calculating upgrade…
2024-04-10 10:23:01,468: INFO - + The following NEW packages will be installed:
2024-04-10 10:23:01,468: INFO - + apparmor firmware-linux-free libabsl20200923 libavif9 libde265-0 libgav1-0
2024-04-10 10:23:01,469: INFO - + libheif1 linux-image-5.10.0-28-amd64
2024-04-10 10:23:01,471: INFO - + The following packages will be upgraded:
2024-04-10 10:23:01,472: INFO - + adduser base-files bind9-dnsutils bind9-host bind9-libs bsdextrautils
2024-04-10 10:23:01,472: INFO - + bsdutils cpio curl dbus debian-archive-keyring distro-info-data dpkg
2024-04-10 10:23:01,473: INFO - + dpkg-dev fdisk file grep grub-common grub-pc grub-pc-bin grub2-common
2024-04-10 10:23:01,473: INFO - + isc-dhcp-client isc-dhcp-common krb5-locales libblkid-dev libblkid1 libbsd0
2024-04-10 10:23:01,474: INFO - + libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libcups2 libcurl3-gnutls
2024-04-10 10:23:01,474: INFO - + libcurl4 libdbus-1-3 libdpkg-perl libfdisk1 libflac8 libgd3 libglib2.0-0
2024-04-10 10:23:01,474: INFO - + libglib2.0-bin libglib2.0-data libglib2.0-dev libglib2.0-dev-bin
2024-04-10 10:23:01,475: INFO - + libgnutls-dane0 libgnutls-openssl27 libgnutls28-dev libgnutls30
2024-04-10 10:23:01,475: INFO - + libgnutlsxx28 libgssapi-krb5-2 libjson-c5 libk5crypto3 libkrb5-3
2024-04-10 10:23:01,475: INFO - + libkrb5support0 liblua5.3-0 libmagic-mgc libmagic1 libmariadb3 libmount-dev
2024-04-10 10:23:01,475: INFO - + libmount1 libncurses6 libncursesw6 libnftables1 libnghttp2-14 libopendkim11
2024-04-10 10:23:01,476: INFO - + libperl5.32 librbl1 libsmartcols1 libssh-gcrypt-4 libssl-dev libssl1.1
2024-04-10 10:23:01,476: INFO - + libtiff5 libtinfo6 libtomcat9-java libudev1 libunbound8 libuuid1 libuv1
2024-04-10 10:23:01,476: INFO - + libuv1-dev libvbr2 libvpx6 libwebp-dev libwebp6 libwebpdemux2 libwebpmux3
2024-04-10 10:23:01,477: INFO - + libx11-6 libx11-data libx11-dev libx11-xcb1 libxml2 libxpm4 libzmq5
2024-04-10 10:23:01,477: INFO - + linux-image-amd64 linux-libc-dev locales logrotate lua5.3
2024-04-10 10:23:01,477: INFO - + mariadb-client-10.5 mariadb-client-core-10.5 mariadb-common mariadb-server
2024-04-10 10:23:01,478: INFO - + mariadb-server-10.5 mariadb-server-core-10.5 mount nano ncurses-base
2024-04-10 10:23:01,478: INFO - + ncurses-bin ncurses-term nftables opendkim-tools openjdk-11-jre-headless
2024-04-10 10:23:01,478: INFO - + openssh-client openssh-server openssh-sftp-server openssl perl perl-base
2024-04-10 10:23:01,479: INFO - + perl-modules-5.32 php-common php7.4-cli php7.4-common php7.4-curl php7.4-fpm
2024-04-10 10:23:01,479: INFO - + php7.4-gd php7.4-intl php7.4-json php7.4-ldap php7.4-mbstring php7.4-mysql
2024-04-10 10:23:01,479: INFO - + php7.4-opcache php7.4-readline php7.4-xml postfix postfix-ldap postfix-pcre
2024-04-10 10:23:01,479: INFO - + python3-distro-info systemd-sysv tar tomcat9 tomcat9-common tzdata udev
2024-04-10 10:23:01,480: INFO - + util-linux util-linux-locales uuid-dev yunohost yunohost-admin
2024-04-10 10:23:02,628: INFO - + 148 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
2024-04-10 10:23:02,629: INFO - + Need to get 16.3 kB/200 MB of archives.
2024-04-10 10:23:02,629: INFO - + After this operation, 325 MB of additional disk space will be used.
2024-04-10 10:23:02,630: INFO - + Err:1 Index of /php/ bullseye/main amd64 php-common all 2:93+0~20230409.46+debian11~1.gbpdb4dcc
2024-04-10 10:23:02,630: INFO - + 404 Not Found [IP: 2400:52e0:1e02::1072:1 443]
2024-04-10 10:23:02,633: WARNING - E: Failed to fetch https://packages.sury.org/php/pool/main/p/php-defaults/php-common_93%2B0~20230409.46%2Bdebian11~1.gbpdb4dcc_all.deb 404 Not Found [IP: 2400:52e0:1e02::1072:1 443]
2024-04-10 10:23:02,634: WARNING - E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
2024-04-10 10:23:03,902: WARNING - Could not upgrade packages: adduser, base-files, bind9-dnsutils, bind9-host, bind9-libs, bsdextrautils, bsdutils, cpio, curl, dbus, debian-archive-keyring, distro-info-data, dpkg-dev, dpkg, fdisk, file, grep, grub-common, grub-pc-bin, grub-pc, grub2-common, isc-dhcp-client, isc-dhcp-common, krb5-locales, libblkid-dev, libblkid1, libbsd0, libc-bin, libc-dev-bin, libc-l10n, libc6-dev, libc6, libcups2, libcurl3-gnutls, libcurl4, libdbus-1-3, libdpkg-perl, libfdisk1, libflac8, libgd3, libglib2.0-0, libglib2.0-bin, libglib2.0-data, libglib2.0-dev-bin, libglib2.0-dev, libgnutls-dane0, libgnutls-openssl27, libgnutls28-dev, libgnutls30, libgnutlsxx28, libgssapi-krb5-2, libjson-c5, libk5crypto3, libkrb5-3, libkrb5support0, liblua5.3-0, libmagic-mgc, libmagic1, libmariadb3, libmount-dev, libmount1, libncurses6, libncursesw6, libnftables1, libnghttp2-14, libopendkim11, libperl5.32, librbl1, libsmartcols1, libssh-gcrypt-4, libssl-dev, libssl1.1, libtiff5, libtinfo6, libtomcat9-java, libudev1, libunbound8, libuuid1, libuv1-dev, libuv1, libvbr2, libvpx6, libwebp-dev, libwebp6, libwebpdemux2, libwebpmux3, libx11-6, libx11-data, libx11-dev, libx11-xcb1, libxml2, libxpm4, libzmq5, linux-image-amd64, linux-libc-dev, locales, logrotate, lua5.3, mariadb-client-10.5, mariadb-client-core-10.5, mariadb-common, mariadb-server-10.5, mariadb-server-core-10.5, mariadb-server, mount, nano, ncurses-base, ncurses-bin, ncurses-term, nftables, opendkim-tools, openjdk-11-jre-headless, openssh-client, openssh-server, openssh-sftp-server, openssl, perl-base, perl-modules-5.32, perl, php-common, php7.4-cli, php7.4-common, php7.4-curl, php7.4-fpm, php7.4-gd, php7.4-intl, php7.4-json, php7.4-ldap, php7.4-mbstring, php7.4-mysql, php7.4-opcache, php7.4-readline, php7.4-xml, postfix-ldap, postfix-pcre, postfix, python3-distro-info, systemd-sysv, tar, tomcat9-common, tomcat9, tzdata, udev, util-linux-locales, util-linux, uuid-dev, yunohost-admin, yunohost
2024-04-10 10:23:03,904: SUCCESS - System upgraded

There may be an issue with IPv6 connectivity:

2024-04-10 10:23:02,630: INFO - + 404 Not Found [IP: 2400:52e0:1e02::1072:1 443]

Yes, let’s do that!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.