Can't login as YunoHost user


#1

Experiencing an issue where after entering in my username and password the login screen just clears itself rather than granting access. I know the credentials are correct because if I deliberately enter wrong details I get an invalid username / password error. I can still access the admin panel fine by directing browser to the server’s local IP address. It means though that I cannot access any apps that are not made public.

I am unsure as with the problems I was having with Wordpress if this is a result from changing my domain settings. Originally I setup YunoHost on mydomain.com - however, after realising that only one app can be given root path on any domain I set admin.mydomain.com to the default instead. It continued to work fine at first but issue arose after restarting the server.


#2

You can try yunohost service regen-conf to regenerate the service files.


#3

Magic thanks! Had to clear cache as well afterwards but everything appears to be working again.


#4

Hello, I’m having the same issue of not being able to log in yunohost as user.
I tried running yunohost service regen-conf and also clear cache with sync && echo 3 > /proc/sys/vm/drop_caches (not sure that’s the right way to do it).
It didn’t solve the issue.

I wonder if it could be related to the fact that I just deleted the first user I had created when installing debian, because otherwise yunohost wouldn’t let me create a user with the same name.
To delete the user, I simply did: userdel -r <username> (this user wasn’t a yunohost user, just a user in the machine).


#5

Ok my misunderstanding, you meant to clear the cache of the browser.
Doing it solved the issue.