Can't install zerotier or zerotier-ui

My YunoHost server
Hardware: odroidu3 armhf
YunoHost version: newest
I have ssh and the web panel
nothing changed in the system

Description of my issue

Yunohost seemed to install perfectly on debian bullseye. I deployed zerobin on a domain succesfully.
I cannot get zerotier to install. I’ve tried in the admin panel, and in cli, and the ‘testing’ branch on github.
Zero tier fails to install no matter what I do:

I don’t know much about zerotier but the important error message is:

2023-03-08 20:07:17,420: DEBUG -  zerotier-ynh-deps depends on zerotier-one (= 1.10.2); however:
2023-03-08 20:07:17,421: DEBUG -   Version of zerotier-one on system is 1.10.4.

Oh, I had test installed it via apt-get after it failed on yuno initially. I purged it, then tried in yuno again. It’s the ‘dependencies’:

So apparently v1.10.4 just came out, the yuno needs v1.10.2

Damnit sorry… I guess they remove/hide the older versions in their repository as soon as a new release is out.

That forces us to update the app instantly… checks GitHub aaaaand our auto-updater was actually disabled.

If you are eager to install it, use the command line: sudo yunohost app install -F, or wait the end of the day for it to have been merged in the main branch.

1 Like

Thx! Problem solved

I tried upgrading zerotier from version 1.10.2 to 1.10.4 but it failed now I am unable restore backup nor able to install new version or testing branch version.

I am running yunohost_version: 11.1.15

initial upgrade failed logs:

fresh install failed logs:

can you please help me with how you were able to fix it?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.