Can't install SSL certificate on a subdomain

My YunoHost server

Hardware: Raspberry Pi 4 8GB, YunoHost installed on microSD card
YunoHost version:
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello all,
I am a newbie and have difficulties creating the SSL certificate for a subdomains which is required to install some apps.

My server runs on and is accessible from within the local wi-fi and from outside as well.

For the first subdomain could create a SSL after I entered the line into * nano /etc/hosts (I got this tip from someone in a support chat). After this, the Let’s encrypt certificate could be installed.

I tried the same for the second subdomain, but now the Let’s encrypt certificate is not installable (button is light green).

I checked Diagnosis, but there is no error in DNS or Web.

What am I doing wrong? Am I perhaps only allowed to create one such subdomain? But then, how can I install the apps that require a subdomain of their own?


The steps you should follow :

  • Create a subdomain in the webadmin

  • Edit /etc/hosts and add two lines
  • Launch the diagnosis

  • Go to domains and install the new certificate

Thanks, jarod5001, it worked!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.