Can't install Searx after Yunohost upgrade to Bullseye

,

Hi guys and girls,

i am new to the forum and start rightaway with a question.
My Yunohostserver, wich is running on an ancient Asus eeepc, won’t let me install searx again, after updating from Buster to Bullseye. Would pleas someone kindly taka a look at the log and find possibly a solution to get it back to work? Thank you very much in advance!!!

ERROR: Command errored out with exit status 1:
Warnung: command: /opt/yunohost/searx/bin/python3 /tmp/tmp8kgnlejv_in_process.py build_wheel /tmp/tmpvjcdr_i5
Warnung: cwd: /tmp/pip-install-6ykvd2xg/pyyaml_8ee812b115b941d1b87ece257a504bf8
Warnung: Complete output (83 lines):
Warnung: running bdist_wheel
Warnung: running build
Warnung: running build_py
Warnung: creating build
Warnung: creating build/lib.linux-i686-3.9
Warnung: creating build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/resolver.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/reader.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/events.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/parser.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/composer.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/dumper.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/cyaml.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/scanner.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/tokens.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/constructor.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/init.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/emitter.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/representer.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/serializer.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/loader.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/nodes.py → build/lib.linux-i686-3.9/yaml
Warnung: copying lib/yaml/error.py → build/lib.linux-i686-3.9/yaml
Warnung: creating build/lib.linux-i686-3.9/_yaml
Warnung: copying lib/_yaml/init.py → build/lib.linux-i686-3.9/_yaml
Warnung: running build_ext
Warnung: creating build/temp.linux-i686-3.9
Warnung: creating build/temp.linux-i686-3.9/yaml
Warnung: i686-linux-gnu-gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O2 -Wall -g -ffile-prefix-map=/build/python3.9-hfHQKB/python3.9-3.9.2=. -fstack-protector-strong -Wformat -Werror=format-security -g -fwrapv -O2 -fPIC -I/opt/yunohost/searx/include -I/usr/include/python3.9 -c yaml/_yaml.c -o build/temp.linux-i686-3.9/yaml/_yaml.o
Warnung: In file included from yaml/_yaml.c:744:
Warnung: yaml/_yaml.h:2:10: fatal error: yaml.h: Datei oder Verzeichnis nicht gefunden
Warnung: 2 | #include <yaml.h>
Warnung: | ^~~~~~~~
Warnung: compilation terminated.
Warnung: Error compiling module, falling back to pure Python
Warnung: running install
Warnung: running install_lib
Warnung: Traceback (most recent call last):
Warnung: File “/tmp/tmp8kgnlejv_in_process.py”, line 280, in
Warnung: main()
Warnung: File “/tmp/tmp8kgnlejv_in_process.py”, line 263, in main
Warnung: json_out[‘return_val’] = hook(**hook_input[‘kwargs’])
Warnung: File “/tmp/tmp8kgnlejv_in_process.py”, line 204, in build_wheel
Warnung: return _build_backend().build_wheel(wheel_directory, config_settings,
Warnung: File “/usr/lib/python3/dist-packages/setuptools/build_meta.py”, line 216, in build_wheel
Warnung: return self._build_with_temp_dir([‘bdist_wheel’], ‘.whl’,
Warnung: File “/usr/lib/python3/dist-packages/setuptools/build_meta.py”, line 202, in _build_with_temp_dir
Warnung: self.run_setup()
Warnung: File “/usr/lib/python3/dist-packages/setuptools/build_meta.py”, line 145, in run_setup
Warnung: exec(compile(code, file, ‘exec’), locals())
Warnung: File “setup.py”, line 288, in
Warnung: setup(
Warnung: File “/usr/lib/python3/dist-packages/setuptools/init.py”, line 153, in setup
Warnung: return distutils.core.setup(**attrs)
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/core.py”, line 148, in setup
Warnung: dist.run_commands()
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/dist.py”, line 967, in run_commands
Warnung: self.run_command(cmd)
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/dist.py”, line 986, in run_command
Warnung: cmd_obj.run()
Warnung: File “/usr/lib/python3/dist-packages/wheel/bdist_wheel.py”, line 259, in run
Warnung: self.run_command(‘install’)
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/cmd.py”, line 313, in run_command
Warnung: self.distribution.run_command(command)
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/dist.py”, line 986, in run_command
Warnung: cmd_obj.run()
Warnung: File “/usr/lib/python3/dist-packages/setuptools/command/install.py”, line 61, in run
Warnung: return orig.install.run(self)
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/command/install.py”, line 578, in run
Warnung: self.run_command(cmd_name)
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/cmd.py”, line 313, in run_command
Warnung: self.distribution.run_command(command)
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/dist.py”, line 985, in run_command
Warnung: cmd_obj.ensure_finalized()
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/cmd.py”, line 107, in ensure_finalized
Warnung: self.finalize_options()
Warnung: File “/usr/lib/python3/dist-packages/setuptools/command/install_lib.py”, line 17, in finalize_options
Warnung: self.set_undefined_options(‘install’,(‘install_layout’,‘install_layout’))
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/cmd.py”, line 290, in set_undefined_options
Warnung: setattr(self, dst_option, getattr(src_cmd_obj, src_option))
Warnung: File “/usr/lib/python3/dist-packages/setuptools/_distutils/cmd.py”, line 103, in getattr
Warnung: raise AttributeError(attr)
Warnung: AttributeError: install_layout
Warnung: ----------------------------------------
Warnung: ERROR: Failed building wheel for pyyaml
Warnung: ERROR: Could not build wheels for pyyaml which use PEP 517 and cannot be installed directly

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.