Can't install plugins and themes - may be permission issue

Hardware: VPS bought online
YunoHost version: (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: Peer Tube app 6.0.3~ynh1

Description of my issue

As Admin of the instance:

  1. I try to install Live Chat plugin 8.4.0

  2. click on install button via web browser

  3. no way to install the plugin

  4. I try to install dark 2.5.0

  5. click on install button via web browser

  6. no way to install the theme

Also tried with other plugins with no success, it sems to be a permissions issue

Hello! Is this related to Can't update/ reinstall Livechat Plugin to 8.4.0 ?

Thank you for investigating, though to help us help you do not be vague and provide peertube’s service logs (right after truggering an error, with YunoPaste, not Hedgedoc) and maybe screenshots. :slightly_smiling_face:

Yes it is related.


I do not see any error related to the livechat plugin installation in the logs. What’s displayed on the Peertube’s page? Only a loading “Install” button?

I only have a mobile phone with me for the next couple of days, so I will not be able to replicate the issue. Can you try to increase the log verbosity to debug and see if the logs are more talkative?

Can you also share the logs after trying to install a theme?

Logs installing the theme dark: hastebin

Don’t know how to get verbose logs. Is there a way to install plugins and themes via the terminal?

May be the PT Admin account hasn’t privileges to install plugins and other?

You can try to install the peertube-cli with those commands :

sudo yunohost app shell peertube
npm install @peertube/peertube-cli

The first command place you in the peertube bash environnement avoiding to touch any other app and setting than Peertube. The second install the JS peertube-cli programs. (But for me, when I tried (once) it didn’t work, don’t know why. You can exit this peertube environment with exit command.

After that you can manipulate plugins with this doc : CLI tools guide | PeerTube documentation

1 Like

Thank you. I’ll try an let you know

The problem seems to be solved. Was an ipv6 connectivity issue but I had to deactivate it on my instance.
It seems that the Contabo ipv6 configuration conflicts with something on the YH suggested config:

This suggested configuration is for OVH. You have to check your provider’s documentation. :wink:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.