Can't install PeerTube App

My YunoHost server

Hardware: VPS bought online
YunoHost version: (stable)
I have access to my server : Through SSH | through the webadmin |
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

If your request is related to an app, specify its name and version: Peer Tube 6.0.3~ynh1

Description of my issue

Get an error and installation aborted. Tried via terminal and via web.


Try this fix for the logs: sudo yunohost app install -f

Dear tituspijean,

thanks for your help but it didn’t work.

Same error:

Mmmh, weird, we will need to investigate further. Sorry for the inconvenience. :confused:

1 Like

Same issue with Fittrackee, seems to be a change in the core recently?

chmod -R 750 fixes the issue, but I don’t know at wich point it’s a good practice for the logs :innocent:

And same with Minetest (not during update, but on service start, after an update)

ERROR[Main]: An unhandled exception occurred: "Failed to open log file /var/log/minetest/minetest.log: Permission denied"

I manually fixed this on my side, but if many apps have the same problem at the same time, it may indeed be due to a YunoHost problem.

There indeed was a recent change with fix logs folders perms by OniriCorpe · Pull Request #1774 · YunoHost/yunohost · GitHub, and chmod 640 is incorrect for opening a directory. I’ll propose a hotfix.

Hotfix: Fix logs directories access by tituspijean · Pull Request #1787 · YunoHost/yunohost · GitHub
New YNH release hopefully soon.


Looking forward to the new relase!

Thank you!

oupsi my bad :stuck_out_tongue_closed_eyes:

the new release will be done this night and should be available shortly after ^w^


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.