Can't install NocoDB on YH11.0.10.1

My YunoHost server

Hardware: Old computer, detailed specs in my profile. Just an old Lenovo M83 SFF upgraded with larger HDD and more RAM.
YunoHost version: (Stable)
I have access to my server : Direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: I have installed GNOME GUI and Teamviewer because monostyle fonts scare me and CLIs are terrifying to me. But this has been since the very start and hasn’t resulted in any errors for other applications.

Description of my issue

My entire world is up in flames as I can’t get NocoDB to install on my server, absolutely tragic. I have updated everything and even rebooted my machine in the hopes of getting it to work, with no (positive) result.

Trying to resolve this by myself at first, I saw that there were some issues with version dependencies of TypeDoc and TypeScript. I noted the versions that were installed before I changed anything, which were:
TypeDoc: 0.23.18
TypeScript: 4.8.4

In the log (see link for full log below), just above the line

npm ERR! npm ERR! Fix the upstream dependency conflict, or retry

there’s a lot of mentions of various versions of TypeDoc and TypeScript so I just tried installing various versions of them both and installing NocoDB, without any result - so I reverted back to what I started with.

I am trying to install it on a subdomain “” but I’m not sure if that’s got anything to do with the errors I’m getting, as I know some apps only work on subdomains/subfolders. I’ve also played with the toggle of “Should this app be visible to anonymous users?” and neither way works.

Am I having a randy moment and just overlooking something simple, or could this be a temporary thing due to an updated version of the app for which certain updates just haven’t gone through to YH yet? I tried this yesterday late-afternoon, too - but same failing story.

Any help is appreciated! (Please be as detailed as possible if you can be of help because I’m also interested in learning - besides just solving the problem :slight_smile:)

If more info is required, just let me know. My first post here on the forum, so just tell me what can be of more help!

There is an ongoing Pull Request to fix that on the testing branch of NocoDB_ynh repository on GitHub
You can test it.

Yep, the testing branch does indeed allow the install to finally round up successfully. Thank you!

So, I’m guessing it’s a matter of patience for me? :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.