Can't install Mastodon

My YunoHost server

Hardware: Hetzner cloud
YunoHost version:
I have access to my server : through both
Are you in a special context no

Description of my issue

When I try to install Mastodon I get an “error in the install script”.

1 Like

I had that too, but it was because I was installing on a Rasperry Pi and I didn’t have enough RAM – Mastodon requires at least 4GB RAM whereas I only had 1GB.
I don’t know if this helps, but that was the problem for me.

No its not that. Just upgraded RAM and the error persists.

1 Like

The issue seems to be Ruby related. Did you use the 64bit or 32bit image? I can’t get Mastodon installed using the 32bit image.

I don’t know. Whichever yunohost installs by default.

I just tried yesterday too and got this error:

Can you share the result of uname -m ?


soon lots of apps needs to be updated, not sure why most of them works on v10 then v11
who ever is the dev is needs to check into the apps and make sure all apps that is listed is working, and if not the dev needs to pull them out and plan a new update or find something else to replace it with…

i had the same issue and yet it looks like this app is outdated…

Then it’s 64 bits.

Similar problem here while installing Mastodon. Although I get a “permission denied” error:

I have the same issue. I understand the Mastodon package was upgraded a couple of weeks ago… The key message in the log seems to be
LoadError: Could not open library ‘/var/www/mastodon/live/vendor/bundle/ruby/3.0.0/gems/blurhash-0.1.6/lib/…/ext/blurhash/’: /var/www/mastodon/live/vendor/bundle/ruby/3.0.0/gems/blurhash-0.1.6/lib/…/ext/blurhash/ cannot open shared object file: No such file or directory

1 Like

Just did a fresh yunohost install and still unable to install Mastodon.

Now it appears that Mastodon was removed from the app catalog, not sure if this was intentional or not.

glitch-soc (Mastodon fork) no longer installs either - same error in same place - to do with Ruby but glitch-soc is still listed as a viable app in the Admin interface. It’s not.

1 Like

Same error here too. 64bits.
Updating ruby version to 3.0.4 (as required by tootctl, see related github issue) doesn’t solve it.
(You can test it in the pull request I made, if you wish to)

1 Like

This is unfortunate as Mastodon was my main reason for trying out YH. I was hoping it would be an easy fix for them.

1 Like

Mastodon should be working by now.
sudo yunohost app install
Catalog app level isn’t updated yet.


Thank you.