Can't get any applications

My YunoHost server

Hardware: VPS bought online
YunoHost version:
I have access to my server : SSH and Webpanel
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hey everyone! I am having a issue with my YunoHost Server. I am running off a VPS that I have bought, and the installation for YunoHost seems fine (running Debian 11 btw) and I can access my panel via the IP, but the problem is when I try to install an application like eg. Gitea, I am getting the 500 Internal Server Error with the action being "GET" /yunohost/api/apps/manifest?app=gitea&locale=en and the Error Message Could not fetch source files, is the URL correct? I already have reinstalled YunoHost several times, what am I doing wrong? Also little side note, I also can’t reach the user interface since isn’t working for me atleast :frowning:

If you start a diagnostic, have you some errors ?

Yes I have some.

On Internet connectivity I have:
[ERROR] Domain name resolution seems to be broken for some reason... Is a firewall blocking DNS requests?

On System Configuration I have:

[WARNING] Configuration file /etc/ssh/sshd_config appears to have been manually modified.

[ERROR] The SSH configuration appears to have been manually modified, and is insecure because it contains no 'AllowGroups' or 'AllowUsers' directive to limit access to authorized users.

I have added [WARNING] and [ERROR] brackets just for the convienience as I can’t make a YunoPaste

Alright, look to fix the firewall error. I think it’s one important mistake. Have you followed the documentation about this subject ?.

I don’t have a VPS solution, maybe a setting with your server ?

For me everything seems alright.
The VPS Hoster normally allows port-forwarding as other services I hosted there worked. I have also read the documentation and everything seems fine to me. If this is important, I have tried enabling UPnP but it gave me an error stating there were no devices.

Sorry, once again ; I don’t have wide knowledge with the VPS and DNS config. Who are your DNS host ? Curious, sometime the error are not really explicit and maybe we don’t check the good thing :confused:


before you’re trying sort of things, please answer this
have you tried to modify any files?
cause the server complaint about ssh modifications manually,

follow these steps before you’re trying anything,
open your ssh console
install nmap
sudo apt-get install nmap

after you done, check if what ports are open for your server,
the commands goes like this:

paste here your results so it might easier for me to analyze,


Installing nmap fixed it! Thank you alot and also stilobique too!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.