Can't change memory footprint of my_webapp

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.2.3
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: my_webapp 1.0~ynh14

Description of my issue

Hi guys,

I’m having an issue with getting 502 Bad Gateway after trying to expand the memory footprint of one of my custom webapps. Seems like it’s stuck on the lowest setting. Whatever I select from the dropdown shows “Nothing has changed” in the log after I click save. I tried to expand it manually by adding php_value[memory_limit] = 64M in the php-fpm confing file of the app and reloading it but no luck.

Any ideas?

Got it working again by changing the PHP version to an older and back to the latest. But get the same problem if I try to edit the footprint again.

Found a solution to manually expand the memory limit:
In the PHP-FPM config of the app add php_admin_value[memory_limit] = 64M because without the “admin” keyword you can’t override the setting.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.