Can't access user interface

My YunoHost server

Hardware: Dell Inspiron 7352 Laptop (Windows 10) - Using Virtual Box 64 bits
Network Setup: Modem + Dedicated router (So 2 separate units)
YunoHost version: Latest (As of Oct 22, 2022)
I have access to my server : Direct access via keyboard/screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : No
If yes, please explain: N/A

Description of my issue

This is my first time trying to self-host, apologies if I forgot to provide some usually expected info. I am trying to self host because I want to use this app: “FireFly III” (

I set everything up using the Virtual Box install option and everything went fine.

These are my Virtual Box network settings:

I typed in my server’s local IP address to get to the admin web login page. Logged in without issues, and ran the initial diagnosis.

I seem to be having issues with port exposure. None of the ports needed are reachable from the outside. Everything is okay with the base system, internet connectivity, and DNS records.

I also get a warning saying that my domain appears unreachable through HTTP from outside the local network.

The email module also seems to have some issues saying:
The SMTP mail server is unreachable from the outside on IPv4. It won’t be able to receive emails. Apparently, my IP is also blacklisted in some places.

Clicking the “access user interface” button leads to a webpage that times out.

I suspect the issue is with port forwarding, and logged into my modem and router control panels online. However, my router shows only one connected device: My laptop. It does not show the YunoHost server running on my machine as a separate client. How do I setup port forwarding then?

I believe the first part is to tell my modem forward all the ports needed to the router’s IP address, and then tell the router to forward the ports to my server.

But my server does not show up in the router’s connected device list.

I tried an experiment by setting up rules for port 80 and port 443 in my modem and router, but those ports are still being shown as inaccessible.

Link to diagnosis logs:

I set my modem to Bridge mode (was in router mode before), and then setup port forwarding settings to my server’s local IP on my router (even though the router did not list my server’s IP as a client).

Seems to have worked, and almost all Ports are exposed now, and I can access the user interface and just logged in as a user.

I got the new diagnosis logs, as there still seems to be a few misconfigured settings.
But clicking the “Share logs” button does not do anything now (Tried logging out and back in, no luck).

Okay, the share link just worked. Here are the logs:

Registered and logged into FireFly III, but their webapp is warning me that: Firefly III is unable to format monetary amounts because your server is missing the required packages.

They provide a link to setup these packages, but I don’t really understand what to do. Help?

Link Firefly gave: Locales - Firefly III documentation

Port 25 not being reachable may be due to your ISP’s “safety rules” against spam. Some allow you to enable it manually from your ISP’s user panel. Reverse DNS might also be configurable with your ISP. If not, you are stuck. :confused:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.