Can't acces admin-menu via Nextcloud, while adjusting settings via the Yunhost admin-page (CLI) also does not work

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: 4.3.5
I have access to my server : Through SSH | through the webadmin | d
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

I succesfully installed Yunhost and the app nextcloud on my raspbarry PI, and use it for a few weeks. (Great to have this running at home, independent of google or dropbox. :smiley:)
Now, the SD card is too small, so I connected an external harddisk, and mounted it.
But how can I configure Nextcloud to use the external disk ?
Namely:
When I go to the Yunohost admin (CLI), click Applications, and click the button “Config panel”, I get the error-message:

*#### YunoHost encountered an internal error*
***Error**: `"500" Internal Server Error*
***Action**: `"GET" /yunohost/api/apps/nextcloud/config-panel?full&locale=nl*
*Config panel versions '0.1' are not supported.*

If found on the internet that Configuring Apps via CLI is still in kind of beta phase, so I tried to configure it directly in Nextcloud.
But now I also cannot find the Admin page of Nextcloud…
I understood that I should find it by opening Nextcloud as the admin user, so I logged in as the first user I made. On the right above corner, I clicked on my picture/logo, getting the drop-down menu. It gives a list of options (Set status, Settings, Apps, About, Users, Help, Log out), but no Admin - option…
So I don’t know how to access Nextcloud settings as an admin.
Questions:
Is the error, when configuring Nextcloud via the CLI, solvable ?
How can I access the admin page of Nextcloud ? (or is it maybe disabled by Yunohost to enforce to use the CLI ?)
Should I check if I’m indeed an admin user (and how) ? (I cannot access the admin pages, and don’t know how to check in terminal mode).

Looking forward to your reaction.

Best regards,
Peter Hoksbergen

You can begin with this
https://yunohost.org/en/app_nextcloud#AddSpace
And as you login with the first user, you’re admin of yunohost and nextcloud.
In the nextcloud app you click on your profile > settings.
There you 'll find your personal settings and when you scroll down you’ll see the administration section.

Hi Jarod,
Thanks.
I actually found the administration part also, though I tried a lot the last time.
I listed the directory yunohost.multimedia on the external harddisk.
Now I find that it only works when I give full (chmod -R 777) access to it.
I think I will need to add a group (in terminal mode), add the current users to it, and then do a chmod 770 to limit the rights for “anyone”, right ?

peter

Yes, as described in the documentation

Thanks for the tip :blush:
Well I did, and got stuck on the last step (scanning the new directory by Nextcloud):
As root@hoks, located in /var/www/nextcloud, I typed “sudo -u nextcloud php7.3 occ files:scan --all”.
I got the error:

An unhandled exception has been thrown:
OC\HintException: [0]: Memcache \OC\Memcache\APCu not available for local cache (Is the matching PHP module installed and enabled?)

PHP seems to be started because systemctl gives:
"php7.3-fpm.service ,loaded, active running, The PHP 7.3 FastCGI Proce " and
"phpsessionclean.timer ,loaded, active waiting, Clean PHP session files…etc,etc

What could be wrong?

In Nextcloud the “Shared Multimedia” is linked to the external harddisk, and it seems to work. But maybe unreliable, or so?

Try this and relaunch the scan

sudo -u nextcloud /usr/bin/php7.3 --define apc.enable_cli=1

It did not react for 1…2 minutes. I broke it with Cntrl-C.
Instead I added “apc.enable_cli=1” in /etc/php/7.3/fpm/php.ini, and rebooted.
I still get the same error after the scan.

Hi Jarod,
After some reading (I’m a bit of newby, but am learning) I found apc.enable_cli=1” should be changed in /etc/php/7.3/cli/php.ini instead of fpm.
So after " root@hoks:~# cd /var/www/nextcloud" and “root@hoks:/var/www/nextcloud# sudo -u nextcloud php7.3 occ files:scan --all” the scan started.
It scanned 2 users, but while scanning the third (which happened to be also the nextcloud admin) it stopped on the error:

Exception during scan: opendir(/home/peter/.gnupg/private-keys-v1.d): failed to open dir: Permission denied
#0 [internal function]: OCA\Files\Command\Scan->exceptionErrorHandler(2, 'opendir(/home/p...', '/var/www/nextcl...', 135, Array)
#1 /var/www/nextcloud/lib/private/Files/Storage/Local.php(135): opendir('/home/peter/.gn...')
#2 /var/www/nextcloud/lib/private/Files/Storage/Common.php(879): OC\Files\Storage\Local->opendir('.gnupg/private-...')
#3 [internal function]: OC\Files\Storage\Common->getDirectoryContent('.gnupg/private-...')
#4 /var/www/nextcloud/lib/private/Files/Cache/Scanner.php(408): iterator_to_array(Object(Generator))
#5 /var/www/nextcloud/lib/private/Files/Cache/Scanner.php(388): OC\Files\Cache\Scanner->handleChildren('.gnupg/private-...', true, 3, 52200, true, 0)
#6 /var/www/nextcloud/lib/private/Files/Cache/Scanner.php(391): OC\Files\Cache\Scanner->scanChildren('.gnupg/private-...', true, 3, 52200, true)
#7 /var/www/nextcloud/lib/private/Files/Cache/Scanner.php(391): OC\Files\Cache\Scanner->scanChildren('.gnupg', true, 3, 588, true)
#8 /var/www/nextcloud/lib/private/Files/Cache/Scanner.php(340): OC\Files\Cache\Scanner->scanChildren('', true, 3, 99, true)
#9 /var/www/nextcloud/lib/private/Files/Utils/Scanner.php(259): OC\Files\Cache\Scanner->scan('', true, 3)
#10 /var/www/nextcloud/apps/files/lib/Command/Scan.php(156): OC\Files\Utils\Scanner->scan('/peter', true, NULL)
#11 /var/www/nextcloud/apps/files/lib/Command/Scan.php(212): OCA\Files\Command\Scan->scanFiles('peter', '/peter', Object(Symfony\Component\Console\Output\ConsoleOutput), false, true, false)
#12 /var/www/nextcloud/3rdparty/symfony/console/Command/Command.php(255): OCA\Files\Command\Scan->execute(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))
#13 /var/www/nextcloud/core/Command/Base.php(168): Symfony\Component\Console\Command\Command->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))                                                                                                                                                            
#14 /var/www/nextcloud/3rdparty/symfony/console/Application.php(1009): OC\Core\Command\Base->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))                                                                                                                                                             
#15 /var/www/nextcloud/3rdparty/symfony/console/Application.php(273): Symfony\Component\Console\Application->doRunCommand(Object(OCA\Files\Command\Scan), Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))                                                                                                    
#16 /var/www/nextcloud/3rdparty/symfony/console/Application.php(149): Symfony\Component\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))                                                                                                                                           
#17 /var/www/nextcloud/lib/private/Console/Application.php(209): Symfony\Component\Console\Application->run(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))                                                                                                                                                  
#18 /var/www/nextcloud/console.php(99): OC\Console\Application->run()
#19 /var/www/nextcloud/occ(11): require_once('/var/www/nextcl...')
#20 {main}

I found this error on a few forums, but without solution.
Nextcloud seems to work (also with the external disk), but sometimes gives “an unknown error occured” when uploading large amounts of files, via the webinterface.