Cannot start dovecot

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.1.17
I have access to my server : VNC console
Are you in a special context, or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I noticed that I cannot access my yunohost website and apps through internet. Also, I cannot access the server through ssh, but I do not know these two are related to each other.

I ran yunohost diagnosis and the only error was:

[ERROR] Service dovecot is failed :(
You can try to restart the service, and if it doesn't work, have a look at the service logs in the webadmin (from the command line, you can do this with 'yunohost service restart dovecot' and 'yunohost service log dovecot').

So I ran the command Yunohost service restart dovecot and it did not work. Here is the output:

Apr 05 12:51:16 systemd[1]: Starting Dovecot IMAP/POP3 email server...
Apr 05 12:51:16 dovecot [12103]: Fatal: service(pop3) access (/usr/lib/dovecot/pop3) failed: No such file or directory Apr 05 12:51:16 dovecot [12103]: master: Fatal: service(pop3) access(/usr/lib/dovecot/pop3) failed: No such file or directory
Apr 05 12:51:16 systemd[1]: dovecot.service: Main process exited, code=exited, status=89/n/a Apr 05 12:51:16 systemd[1]: dovecot.service: Failed with result 'exit-code'.
Apr 05 12:51:16 systemd[1]: Failed to start Dovecot IMAP/POP3 email server.

Let’s run apt install dovecot-pop3d then systemctl restart dovecot

Firstly, thank you for your answer. I installed dovecot-pop3d and successfully restarted dovecot, but I still cannot access yunohost through the internet. Yunohost diagnosis returns no issue.

Edit: I also still cannot ssh to my server

Then please create a different topic with a name referring to this issue and explaining what exactly happen such that you “can’t” access yunohost, i.e. how exactly you are trying to access the server. and what exactly happens

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.