Cannot log into debian server after installing YunoHost

Hello, I have installed Yunohost on a debian 10 vps, im able to log into the web admin and install applications. The issue I have is that I cannot log into my server as root or admin after installing Yunohost. When using ssh root@11.11.11.111 -i ~/.ssh/server (1’s being an example), It gives me a message like “root@11.11.11.111s password:” as oppose to automatically logging me in before with my previous setup. After I input and enter my root password it gives me the message “Permission denied (publickey,password).”

How do I log into my server after Yunohost has changed my password?

What has the password I previously had for root changed to?

Is it possible to reset my password through the new email I created for the first user.

Please get back to me when you can.

Use admin as user not root

1 Like

You log in as admin (with the same password as admin on the web interface), and use sudo (or sudo su -) run commands as root.

Yunohost disables root access from a security standpoint (it notices you of that during install)

Ok thank you that makes sense. But how do I log in as admin on konsole, is it “ssh server-admin@11.11.11.111 -i ~/.ssh/server”? What are the exact commands that I use to log in?

If your Yunohost is at star7.noho.st, then the command would be:

ssh admin@star7.noho.st // or whatever your domain name is!

If you had a couple of failed attemps for log in, maybe fail2ban blocks your connection. In that case you get an error before you can enter your password.

Once you see you can log in, you can make it easier by setting up public key based log in. At your computers (laptop/desktop/phone) end, for your personal account (ie, not as root):

$ ssh-keygen
// the defaults are fine, don't use a passphrase, press enter a couple of times, when it is done: 
$ ssh-copy-id admin@star7.noho.st
// follow the instructions

Now when you ssh admin@..., it will log you in automatically as you were used to.

1 Like

I was able to log in! I had tried figuring out how to log in with no success, and did not see it anywhere in the documentation because I guess it’s assumed users would figure it out? I think your post should be put into the documentation for users new to Linux.
Thank you so much for the clear and concise solution!

1 Like

Great!

Now have a lot of fun with your Yunohost! :slight_smile:

1 Like

Bye, thanks.
Same problem solved this way, but how can I access with FileZilla?
Not possible with the same system.

Thanks for your help

Nice :slight_smile:

FileZilla is a multi-protocol filetransfer client, is it not? Which protocol do you use? How far do you get logging in, and which error does it give?

Once connected, your movement on the filesystem is relatively limited as admin, because of access rights. You should be able to access /home/admin and quite a few others, but many are closed for admin.

Is there a specific directory you want to reach?

To keep things tidy, you might want to start a new thread specific for Filezilla access with reference to this thread. That way other Filezilla users can find it back easily!

By the way, welcome to the forums!

Thank you and nice to meet you in the forum.

From Filezilla there is no connection, it is not a problem to reach a folder or a file, it does not establish the connection to the server via the root credentials that used to work.

I’ve tried with Admin but it doesn’t work; it’s quite a big problem because then you can’t work with all the applications that require work on files such as “Custom Webapp”.

Root will not work indeed, for security root is not allowed remote access (‘root’ is the only user that is available on all Unix-like systems, and has all rights above that. It is to powerful to risk a breach.)

What is ‘it’ in this case? Also the connection? Please start a new thread, and spend a minute reading the helpful text that explains how other people can help you!

1 Like

It is covered in the documentation under Security.

https://yunohost.org/en/security#ssh-authentication-via-key

1 Like

Good catch! @josephflag , also look at the Filezilla-specific page, does it help your case?

1 Like