Cannot install YunoHost in QEMU


My YunoHost server

Hardware: Intel G5420, 16 GB RAM, NVME-SSD
YunoHost version: yunohost-buster-4.1.6-amd64-stable.iso
I have access to my server : Through SSH as well as using virt-manager
special context : yes:
I tried installing yunohost in a QEMU/KVM-VM
I tried using 2 cores and 2048 MB RAM for the VM. The boot-disc is a 200 GB large qcow image on an NVME-SSD and I wanted to mount a folder via QEMU later as a “data partition”. If that’s inappropriate, please recommend better values/approaches.

Description of my issue

The default installer cannot install grub on the disc. When trying to run that step of the installation the error message “GRUB konnte nicht auf /dev/sda installiert werden.”

This strikes me as weird because when launching a shell and running df -h there’s no /dev/sda-disk. Only a /dev/vda-disk. The same issue would arise if you tried to install yunohost on a bare metal machine that is supposed to use an NVME-drive as boot-drive. There the boot drive would be referred to as /dev/nvme0n1.

How can I ensure that grub is installed on /dev/vda?

How can I ensure that no other issues arise later related to /dev/sda apparently being a hardcoded value?

Also the fact that I’m not able to configure the partitioning (combined with the hardcoded disk path) leads me to believe that yunohost tries to install everything on a non-existing disk. Is this the case?

I will let actual experts answer you regarding the VM issues.

Meanwhile, what I suggest you to do is installing Debian 10 first, set your mount points as you wish (YunoHost apps are generally stored in /home, /opt, and /var/www), and then install YunoHost on top of it.

Here is the related documentation page:
You should create the mount points before running curl | bash .

Didn’t know, that you could just install yunohost on top of an already installed debian, thank you very much! I’ll try and see if it works.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.