Cannot install Wordpress on fresh YUNO Host server

My YunoHost server

Hardware: Vultr VPS , 2GB Ram, 1 CPU
YunoHost version: 3.6.5.3
I have access to my server : Through SSH, and through the webadmin, and direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : nothing special

Description of my issue

I did a fresh install with the command prompt on a Debian 9 server because the full ISO install was not working (it was failing at the install software step).

After the fresh install I did the configuration and selected the option to have YUNO create a dynamic DNS domain for me. It seems that this domain was not created which may be causing the issue.

After the configuration I added a user and tried to add the Wordpress application. It was processing for some time but in the end it gave an error and rolled back the installation. Please see attached for the log.

My goal is just to test out YUNO host to see if I can use it for hosting a blog, and other small web sites on a VPS instead of using a provider like Webfaction.

here is the log: paste . yunohost . org / vukafubojo.sql (had to drop the http and add spaces because it says I can’t paste links)

Thank you very much for your time! :slight_smile:

You should now be able to post link.

If you add an error creating the domain, for sure that was what cause the error.
During the install, the script failed to reach the wordpress install page.

Do you know what happened with your domain ?

I’m a bit confused about why the domain is so integral to the Wordpress setup, but anyway I’ve done a fresh install and tried again.

Using the “I don’t have a domain name” option to make a new dynamic one

After clicking OK things seem to go fine, but if I look at the notifications at the top I see this message:

dyndns_provider_unreachable
Invalid url https://dyndns.yunohost.org/domains (does this site exists?)

According to this (https://yunohost.org/#/dns_nohost_me) , I tried again at the command prompt:

root@vultr:~# yunohost dyndns subscribe -d yuno3.nohost.me
Error: https://dyndns.yunohost.org/domains returned status code 500
Error: Could not check if dyndns.yunohost.org can provide yuno3.nohost.me.

Maybe try with noho.st or ynh.fr
Heard that there was recently issues about dyndns domain names. Don’t know much about it though.

Well, you actually did trig an other error on the infra :disappointed_relieved:
You can retry to create the domain now, it should be ok.

Getting closer. Now I see that the domain I was trying to get was already registered. Using the commands I was able to register a domain, but then I saw that the IP wasn’t updated correctly. I ran the yunohost dyndns update command and got this:

update failed: NOTAUTH(BADKEY)
Info: The operation ‘Update the ip associated with your YunoHost subdomain ‘yuno-djx.noho.st’’ has failed! To get help, p lease share the full log of this operation using the command ‘yunohost log display 20200105-002753-dyndns_update-yuno-djx .noho.st --share’
Error: Unable to update IP address on DynDNS

And the log (https://paste.yunohost.org/raw/ganuvodubu) says that it can’t get the IPV6 address.

I saw some other forum posts saying that there are IPV6 limitations for the dyndns, but that post is from 2017. Does this issue still persist?

In my Vultr admin panel it’s pretty easy to enable IPV6 - so I did that and now the DNS seemed to work. I pinged the address from the server itself and it resolves correctly. I tried to install Wordpress and it still didn’t work. From my local machine the name isn’t resolving yet - so I will wait for the DNS to propagate and give it another try.

I used my own DNS to get an address and a Let’s Encrypt certificate. Now when I install I still get the same error:

!!

wordpress’s script has encountered an error. Its execution was cancelled.

e[91me[1m[ERR]e[0m !!

Run wp core install to create database tables.

Error: The site you have requested is not installed.

2020-01-05 03:31:37 URL:https://raw.githubusercontent.com/wp-cli/builds/gh-pages/phar/wp-cli.phar [5568133/5568133] -> “/var/www/wordpress/wp-cli.phar” [1]

I saw another message in the log saying it failed to delete the user wordpress and I realized why the problem was happening. As I expected, it’s probably not related to the domain. The issue is I created a test user called “wordpress” which apparently conflicted with the name the built-in script wanted to use. Once I tried to install with a different username it worked fine.

Without a complete log, I can’t say what’s happening.

The error you see, Error: The site you have requested is not installed. is only a consequence of a the real error happening before.
In your first log, you got a 502.
Now I don’t know.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.