Cannot access nocodb

Hello! I’m trying to install NocoDB on yunohost, and I see no issue, but I cannot access my installation at all.

My YunoHost server

Hardware: linode VPS 8g
YunoHost version: 11.1.4
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I am trying to install nocodb. I tried through both the web admin and the command line tool

It seems to work without any issue.

The service seems to be running:

But, accessing the URL tables.mydomain.tld, I get only my default mydomain.tld static site.

Curling locally does the same:

My guess is that my my_webapp site at the root mydomain.tld is somehow overriding proxy calls for subdomains, but I’m not sure how to change it. It does work for every other yunohost app (I suppose because they’re all PHP apps and don’t require proxy_pass?).

Hope someone can help!

I tried moving the webapp to a sub-url, so now:

  • domain.tld does nothing
  • domain.tld/site is my static site
  • tables.domain.tld is nocodb

And, surprisingly, tables.domain.tld still shows the static site.

I guess that makes sense since curl localhost:8096 from the ssh’ed host also presents me with the same result, but I can’t make sense of it.

Note: no errors in /var/log/nginx/tables.mydomain.tld-error.log


Bonjour! J’essaye d’installed NocoDB, et je n’ai aucune erreur, mais je ne peux pas accéder à mon installation.

À l’installation, il n’y a aucun problème; et si j’essaye de voir le status du service nocodb, tout est bon aussi.

Mais si j’essaye d’accéder à mon domaine tables.mydomain.tld (là où nocodb est installé), j’obtiens le site statique localisé à mydomain.tld.

Si j’essaye curl en local, ça me donne la même chose (la page statique située à mydomain.tld).

J’ai essayé de changer la URL de la webapp, pour que:

  • mydomain.tld soit vide (redirige vers sso)
  • mydomain.tld/site soit mon site statique
  • tables.mydomain.tld soit nocodb

Et, à mon désespoir, tables.mydomain.tld conduit encore au site statique, ce que je ne comprends pas du tout. Comment est-ce que tables.mydomain.tld et domain.tld/site pourraient être la même chose? La config de nginx ne semble pas indiquer ça du tout.

Note: aucune erreur dans /var/log/nginx/tables.mydomain.tld-error.log

Solved! Everything works, you only have to go to tables.domain.tld/dashboard


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.