Can Synapse-Admin access two Synapse-Servers? (NetworkError when attempting to fetch resource)

Hi guys,

I have two Synapse-Servers and want to access through one Synapse-Admin. But I run into an error.

My YunoHost server

Hardware: VPS bought online
YunoHost version: (stable)
I have access to my server : Through SSH + through the webadmin
If your request is related to an app, specify its name and version: synapse-admin 0.8.7~ynh2

Description of my issue

Under one domain ( I have installed the Matrix/Synapse-Server. Under the domain I installed Synapse-Admin. Via CommandLine I could activate the user as admin. I can create users, the users can log in, chat, etc… The whole thing works wonderfully.

Now I wanted to install a second Matrix instance. I took a second domain named and installed Matrix/Synapse-Server again. Unfortunately, a second Synapse admin is not possible. But I seem to be able to change the address of the target system with the Synapse-Admin. I have tried that. I can also log in. In addition, I have activated the first user from the new system as admin in the new instance (matrix_synapse__2) via CommandLine. This also worked. I can login into the admin.

When I want to create a new user, and in fact whenever I load new pages in the admin, the error message “NetworkError when attempting to fetch resource.” appears. A new user is not created. This does not work.

Does anyone have a tip on what I can do? Is it at all possible to manage different Synapse servers with Synapse Admin?

Thanks for your help

Ok, I have now found out that the Error “NetworkError when attempting to fetch resource.” has to do with the use of the different domains. The admin is installed under and the second matrix server under
In the Developer Console of Firefox it says that there are problems with Cross-Origin:
“Cross-source (cross-origin) request blocked: The same-source rule prohibits reading the external resource”.
I have also tried logging in via the public admin (Synapse-Admin). But when doing so, both domains and get the same cross-origin errors.
So how can I fix this?

Ok, ich habe inzwischen rausbekommen, dass der Fehler “NetworkError when attempting to fetch resource.” mit der Nutzung der verschiedenen Domains zu tun hat. Der Admin ist unter installiert und der zweite Matrix-Server unter
In der Developer-Console vom Firefox ist zu lesen, dass es Probleme mit Cross-Origin gibt:
“Quellübergreifende (Cross-Origin) Anfrage blockiert: Die Gleiche-Quelle-Regel verbietet das Lesen der externen Ressource”
Ich habe auch probiert, mich über den Public-Admin (Synapse-Admin) einzuloggen. Aber dabei gibt es bei beiden Domains und die selben Cross-Origin-Fehler.
Wie kann ich das also beheben?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.