Bug during boot / Erreur au démarrage système

,

:uk: Hello everyone,

I usually manage to find a solution on my own, but this time, I must admit I’m struggling a bit.

Server Configuration

Hardware: An old computer with 3 hard drives in a RAID 0 configuration (yes, I know it’s not safe, but it’s old hardware so i don’t car, I just want to test and learn thoroughly before eventually setting up a RAID 5 with 6 SSD - which I currently can’t :moneybag:).
For the RAID setup, I did the following:
Created 3 partitions on each hard drive: one for swap, one for boot, and one for the file system. YunoHost Version: The latest one, I believe.
I have access to my server via: SSH, but due to the issue, only directly with a keyboard and monitor.
Are you in a specific context or have you made any special modifications to your instance? No.

Description of the Problem

I noticed that my server was powered off (which is not normal since it should be running all the time), so I tried to start it, but it entered emergency mode. I can no longer start it in the usual way, and I see this message:

[TIME] Timed out waiting for device /dev/disk/by-uuid/[suite.de.chiffre.1]
[DEPEND] Dependency failed for /boot.
[DEPEND] Dependency failed for Local file Systems.
[DEPEND] Dependency failed for Mounts /proc with hidepid=2.
[DEPEND]  failed for File sustem check on /dev/disk/by-uuid/[suite.de.chiffre.1]

for blkid :

blk_update_request: I/0 error, dev fd0, sector 0 op 0x0:  (READ) flags 0x80700 phys_seg prio class0
blk_update_request: I/0 error, dev fd0, sector 0 op 0x0:  (READ) flags 0x0 phys_seg 1 prio class 0
Buffer I/0 error on dev fd0, logical block 0, async page read
/dev/sdb1: UUID= *[suite.de.chiffre.sdb1]
/dev/sdb2: UUID= *[suite.de.chiffre.2]
/dev/sdb3: UUID= *[suite.de.chiffre.3]
/dev/sda1: UUID= *[suite.de.chiffre.sda1]
/dev/sda2: UUID= *[suite.de.chiffre.2]
/dev/sda3: UUID= *[suite.de.chiffre.3]
/dev/sdc1: UUID= *[suite.de.chiffre.sdc1]
/dev/sdc2: UUID= *[suite.de.chiffre.2]
/dev/sdc3: UUID= *[suite.de.chiffre.3]
/dev/md1: UUID=  *[suite.de.chiffre.md1]
/dev/mapper/mvg-racine: UUID= *[suite.de.chiffre.mvg-racine]

For the “journalctl -xb” command:

I’d be glad to help you with the logs, but I copying from the server to this computer is tricky, maybe by a photography ?

Regarding “nano /etc/fstab” :

I’ve already checked and i didn’t see anything unusual. If you need the contents of that file i can give you if it help in troubleshooting.

Here’s the information i can give you.

What I’d like to do:

  1. Understand what might have caused this issue.
  2. start normally because I’m currently stuck in emergency mode.

If there’s any additional information I can provide you in the evening.
Thanks for any help :slight_smile:

:fr: Bonjour à tous,
Je me débrouille toujours pour trouver une solution par moi même mais la j’avoue je peine un peu.

Configuration du serveur

Matériel: Vieil ordinateur avec 3 disque dur en raid 0 (oui je sais ce n’est pas safe mais c’est du vieux matériel je veux d’abord bien tester, et apprendre à fond sur de l’essai et lorsque j’aurai les moyens je voudrais monter un raid 5 sur 6 SSD ce que je ne peux pour l’instant donc je m’entraine) :wink:
Pour le raid j’ai fais :
3 partitions sur chaque disque avec 1 pour le swap, une pour le boot et une pour le système de fichier.
Version de YunoHost: la dernière ?
J’ai accès à mon serveur : en SSH mais depuis le bug seulement en direct avec un clavier/écran
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifications particulières sur votre instance ? : non

Description du problème

J’ai remarqué que mon serveur était éteint (ce qui n’est pas normal étant donné qu’il devrait être allumé à toute heure), j’ai voulu le démarrer et là, il me passe en émergency mode. Je ne peux plus le démarrer de manière normale avec ce message:

[TIME] Timed out waiting for device /dev/disk/by-uuid/[suite.de.chiffre.1]
[DEPEND] Dependency failed for /boot.
[DEPEND] Dependency failed for Local file Systems.
[DEPEND] Dependency failed for Mounts /proc with hidepid=2.
[DEPEND]  failed for File sustem check on /dev/disk/by-uuid/[suite.de.chiffre.1]

Pour blkid :

blk_update_request: I/0 error, dev fd0, sector 0 op 0x0:  (READ) flags 0x80700 phys_seg prio class0
blk_update_request: I/0 error, dev fd0, sector 0 op 0x0:  (READ) flags 0x0 phys_seg 1 prio class 0
Buffer I/0 error on dev fd0, logical block 0, async page read
/dev/sdb1: UUID= *[suite.de.chiffre.sdb1]
/dev/sdb2: UUID= *[suite.de.chiffre.2]
/dev/sdb3: UUID= *[suite.de.chiffre.3]
/dev/sda1: UUID= *[suite.de.chiffre.sda1]
/dev/sda2: UUID= *[suite.de.chiffre.2]
/dev/sda3: UUID= *[suite.de.chiffre.3]
/dev/sdc1: UUID= *[suite.de.chiffre.sdc1]
/dev/sdc2: UUID= *[suite.de.chiffre.2]
/dev/sdc3: UUID= *[suite.de.chiffre.3]
/dev/md1: UUID=  *[suite.de.chiffre.md1]
/dev/mapper/mvg-racine: UUID= *[suite.de.chiffre.mvg-racine]

Pour le journalctl -xb :
Je vous les partagerai bien mais pour le coup je ne sais pas trop comment copier les logs que m’affiche le serveur à part en photo peut être ?

Pour le nano /etc/fstab :
Je l’ai fais je ne voyais rien de particulier mais j’avoue comme un idiot je n’ai pas pris la photo, je peux vous le rajouter plus tard si besoin…

Voici à peu prêt les informations que je peux vous donner, je ne voulais pas faire n’importe quoi car on trouve pleins de manipulation sur internet mais la plupart sont pour des erreurs entre des UUID et avant de toucher à ce genre de configuration je préfère demander donc voilà. :slight_smile:

ce que j’aimerai :
Comprendre ce qui s’est passé si possible.
puis
Pouvoir démarrer mon serveur normalement car là je reste bloqué en emergency mode.

si j’ai mal décris, n’hésitez pas à me dire pour que j’améliore ma manière de décrire (j’essaierai de modifié en rentrant ce soir) !
Merci d’avance pour ceux qui prendront le temps de répondre :slight_smile:

Salut
A mon avis, tu as un disque de mort

Merci d’avance pour la réponse,
Sauriez vous comment l’on peut tester les disques afin de savoir lequel est mort ?
Bien cordialement

tu peux démarrer d’une iso linux sur clé USB et checker tout ça une fois la live session demarrée

2 Likes

Bonjour,
Désolé pour le retard de réponse j’ai pris quelques vacances. :slight_smile:

voici ce que donne le cat /etc/fstab

@Benance , merci beaucoup pour ton aide, j’avoue que j’ai tenté de démarrer avec une iso de linux mais qu’entend tu par live session ? car il ne me propose que de suivre le programme pour installer linux mais je ne vois aucune catégorie pour faire un check de mon disque dur.

Merci d’avance pour ceux ou celle qui passeront par ici :slight_smile:

Bsr,
Utiliser smartmontools
Voici mon pense bête :wink:

https://cbiot.fr/dokuwiki/freebsd-smartmontools

++
C

1 Like

Salut
Essaie avec une ISO ubuntu ou linux mint ou zorin os

1 Like