Broken system with bookworm/bullseye apt mix

Hi !

Sorry, I came up with a big cascading issue from the same initial situation. I run yunohost 11.2.10.3

After fixing this sury GPG key thing and upgrading my server via the webadmin, some more trouble appeared:

Des erreurs se sont produites lors de la mise à jour du cache APT (gestionnaire de paquets Debian). Voici un extrait des lignes du fichier sources.list qui pourrait vous aider à identifier les lignes problématiques :
sources.list:deb http://deb.debian.org/debian/ bookworm main
sources.list:deb-src http://deb.debian.org/debian/ bookworm main
sources.list:deb http://deb.debian.org/debian/ bookworm-updates main
sources.list:deb-src http://deb.debian.org/debian/ bookworm-updates main
sources.list:deb http://security.debian.org/debian-security bookworm-security main
sources.list:deb-src http://security.debian.org/debian-security bookworm-security main
sources.list.d/yunohost.list:deb http://forge.yunohost.org/debian/ bullseye stable
sources.list.d/extra_php_version.list:deb https://packages.sury.org/php/ bookworm main

Mise à jour du catalogue d'applications...

Le catalogue des applications a été mis à jour !

Failed to read info for grav : Invalid version: '1.7.44~ynh1'

Failed to read info for phpldapadmin : Invalid version: '1.2.6.6~ynh2'

Failed to read info for rainloop : Invalid version: '1.17.0~ynh1'

Failed to read info for redirect : Invalid version: '1.0.2~ynh1'

I tried to fix it via SSH, running manual upgrades/reinstalls with apt but I’m still stuck with these:

The following packages have been kept back:
  dovecot-antispam dovecot-core dovecot-imapd dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-sieve fail2ban ghostscript iptables libalgorithm-diff-xs-perl libclone-perl
  libdbd-mysql-perl libdbi-perl libfcgi-perl libfile-fcntllock-perl libgs9-common libgssapi-perl libhtml-parser-perl libhttp-message-perl libip4tc2 libip6tc2 libiptc0
  liblocale-gettext-perl libnet-dns-sec-perl libnet-libidn-perl libnet-ssleay-perl libnetaddr-ip-perl libnginx-mod-http-auth-pam libnginx-mod-http-cache-purge libnginx-mod-http-dav-ext
  libnginx-mod-http-echo libnginx-mod-http-fancyindex libnginx-mod-http-geoip libnginx-mod-http-geoip2 libnginx-mod-http-headers-more-filter libnginx-mod-http-image-filter
  libnginx-mod-http-lua libnginx-mod-http-ndk libnginx-mod-http-perl libnginx-mod-http-subs-filter libnginx-mod-http-uploadprogress libnginx-mod-http-upstream-fair
  libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-nchan libnginx-mod-stream libnginx-mod-stream-geoip libnginx-mod-stream-geoip2 libsemanage-common libsocket6-perl
  libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libxtables12 nginx-common nginx-extras openssl passwd perl perl-base perl-openssl-defaults postgresql-client-common
  postgresql-common redis-server redis-tools slapd
0 upgraded, 0 newly installed, 0 to remove and 67 not upgraded.

An exemple of what I tried:

$ sudo apt reinstall ssowat
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ssowat : Depends: nginx-extras (>= 1.6.2) but it is not going to be installed
 yunohost : Depends: nginx
            Depends: nginx-extras (>= 1.18) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Now none of my apps are detected by the webadmin, the SSO is defective (can’t connect) and nextcloud is totally broken (postgresql is active tho) :confused:

Thanks in advance for reviewing this!

I have split your message into a new thread, since you seem to have a very different problem.

You seem to have broken your system by replacing most of the Bullseye APT sources by the Bookworm ones. How, and why?

I hope you have made backups. I would advise you to retrieve them and restart from scratch with Debian 11 Bullseye.

If not, resolution is not guaranteed.

First solution: I would replace back all mentions of “bookworm” in /etc/apt/sources.list by “bullseye”.
Then, run sudo apt update and sudo apt upgrade. I am no expert of APT, but I guess that will fail. Share the logs.

Second solution: go further and complete the migration to YunoHost 12. This is still experimental and some apps are still not working. You can refer to the YunoHost 12 testing thread in the Announcements section.

1 Like

Thanks for your reply, I appreciate a lot. I just remembered why I upgraded to bookworm: I needed to install a debian package that was only available on it and I naively believed it wouldn’t cause much trouble…

Well here we are now ^^
I wish I had fresh backups but they’re too old and partial to be useful sadly.
Well I’ll try completing the migration and we’ll see. Hopefully it’s not a super important server, I can find some workarounds while the team manages to make it work as beautifully as usual.

Btw, thanks a lot to every contributor who reads this !

1 Like