Borg Backup 1.1.13 : 17 mails "[YNH] First backup is starting" sent at each backup

My YunoHost server

Hardware: Raspberry Pi 4 at home
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : not really

Everytime borg start a new backup, it sends 17 emails “[YNH] First backup is starting”

Everything is in the title :slight_smile:

So, the backup work and are done.
But every night, when the backup job is launched, I receive 17 emails with this object : “[YNH] First backup is starting”.

I’m not sure when exactly it started because :
1- I realized few days ago that Borg Backup was not working since september 29th. I investigated and didn’t find any reason… Finally I removed the app and re-installed it and it worked perfectly since then.
2- I’m not so sure about when it was exactly, but the borg backup app has been updated after I re-installed it and the 17 emails thing could have started after this update (but I’m not 100% sure)

It’s not very important since the backups work (which is my main concern), but I wonder if anybody else has the same thing happening on his / her server ?

Thanks and have a nice day,

Yes, just after upgrading to Debian 10. Currently, trying to solve that issue as well as why its backing up all the apps except nextcloud_data.

For now, I just commented out the lines for the if statement that does the borg init in /etc/yunohost/hooks.d/backup_method/05-borg_app.

It’s due to a bug in the new borg_ynh version released 4 days ago.

I fix it

I made a small temp fix, it should stop to send you this mail each time…

1 Like

So your backups are working with the repo having ssh:// in front with ~backup mentioned for repo? Because I get errors with that using borgbase as my server.

@Timbo: i think borg_ynh doesn’t support borgbase, see this ticket for more info:

“~/backup/” is hardcoded cause the goals is to simplify as possible. I can probably put a hidden question in manifest to ask for the directory. It will be possible to define it with cli but not with webadmin.

Note: I work on a core integration of borg repo. So this app is not my big priority (it should be replaced by the new core features)

And also:

I close it because there is a ticket for this issue.
When i will improve the PR to integrate borg in yunohost core i will think to this use case.

Hmm, yea I think that a bunch of us thought that this would eventually be incorporated into YH by now with official support. Given that enhancement has been open for nearly 2 years and its even lower priority than when it was first said, it’s probably best to close the enhancement as “won’t fix” or whatever. I did just buy a ton of VPS storage so I could possibly use my own server instead of borgbase, but I didn’t want to sign up for that hassle given how cheap borgbase is (required zero maintenance from me for year+).

I don’t know enough about borg to know if the limitations of specifying “ssh://” and the “~backup” path is a borgbase limitation or a borg code issue. I don’t want to have to go through the hassle of switching borg server to my own and find the repo address still requires modification after every borg update and it was a bunch of hassle without any benefit.


Thank you !

One more question :
I just updated my borg_server to buster and borg is then unable to work.

Here is what I get :

root@box:~# borg
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ImportError: No module named 'encodings'

Thanks in advance for your kind help,

@charly: You need to upgrade borg_ynh and borg_server_ynh after buster migrations.

Yep, I’ve done it.
I also just tried to uninstall borgserver and reinstall it but I’ve got the same message.

Weird no ?

@charly: borg and borgserver are on the same host ?

Nope, but it’s OK, I’m re-installing the borg-server host.
And it’s now working :slight_smile:

Problem solved.

Thanks !

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.