Blurry (fuzzy?) screen after boot

My YunoHost server

Hardware: Older amd64 laptop. Yunohost is installed on bare metal
YunoHost version: latest (?) just downloaded about 3 days ago
I have access to my server : direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : No

Description of my issue

I installed YunoHost on my older HP Elitebook 2570p and after installation I can’t boot into the system. The screen gets all blurry as shown in the picture below. I looked for other questions like this but couldn’t find too many similar ones, certainly not ones with solutions.

I have scoured the internet but couldn’t find anyone who was to solve this. I noticed other cases like this, but they at least had a working mouse pointer. For me, I can’t see anything … Nothing works.

The only thing I see from the boot process are the following two messages echoed to the screen. Afterwards it all get’s screwed up …

Some info about the system:

  • i7-3520m
  • 8GB of RAM
  • About 180GB of SSD

What I tried so far

  • Editing boot options and disabling load_video
  • Adding nomodeset to it
  • Changing different boot modes (Legacy, EFI (with and without CSM))
  • Reinstalling

Other systems (Manjaro, Ubuntu) work just fine. Me posting this is a last ditch effort. I asked around other places as well so I’m putting my last drop of hope on you guys :crying_cat_face: I hope we can figure this out.

ubuntu, manjaro or any other distributions are irrelevant due to they use different stack sometimes than debian,

try to login to the console with F2 once you sees the boot statement
if you already on the console,

try update, and upgrade,
sudo apt-get update && upgrade
if there are any missing dependencies for the driver they should be installed or being upgraded, IF they are available,

the wise thing to do is trying debian installation instead of ubuntu or any other,
just download debian and install without any desktop environment and test, so it will be easier to point that problem to yunohost version of debian,

maybe that way we could think about installing yunohost with repositories instead of the iso,
but we need to make sure that debian have no issue with your drivers,

I tried logging into console as you suggested but didn’t work either. It’s almost as if it gets stuck when the screen tearing happens.

However, I installed Debian Bullseye on the laptop and it works well. I installed an XFCE version as well and that works too.

I’d mention that the strange screen tearing happens after the boot messages are printed to the screen, but the lines disappear after a few seconds and I’m lead to the login screen successfully.

I suppose this means the problem lies with the yunohost version. Maybe the laptopt doesn’t play well with it …

the problem is you did follow my instructions to install deban which is okay but you skipped one step i did ask you to follow,

intentionally i did ask you to install debian without any desktop environment,
once you install desktop environment you changed the whole picture, cause the desktop environment comes with some packages with it such as Directx such as DXVK which can lead easily to your card to be working under such conditions,

your graphic card are able to work with linux that obvious from knowing menjaro, ubuntu do works well with it, but those distributions comes pre stacked with desktop environments which is the difference and its a huge difference,

so now you created a situation which we are not sure what is guilty, the debian or yunohost debian,

please reinstall debian,
and this time don’t install any desktop environment with it, moreover, don’t even install basic system utilities, just debian,

then if it will work well, we will know for sure there is a problem with yunohost version,
and we can ask aleks if there is a way to use repositories to install yunohost on top of your debian,
but now we can’t complaint about anything while we are not fully sure,

just update what’s happening after you done…

by the way don’t try to be clever and remove the desktop environment,
cause once the driver is there its there you don’t know where is it and you don’t know the synaptics left overs, so you have to reinstall,

just remember whatever will happen i always have a solution for you, but i am keeping it as last solution,
lets just try the usual way,

Ok, that makes a ton of sense :slight_smile: Taking notes …

I did as you told me and reinstalled debian without installing anything (not even basic utils). The results are mostly the same, some weird graphical glitching still occurs but I’m once again at the login prompt.

Now however, I see some errors:

i915 0000:00:02.0:  [drm] *ERROR* uncleared fifo underrun on pipe A
i915 0000:00:02.0: [drm] *ERROR* CPU pipe A FIFO underrun
i915 0000:00:02.0: [drm] *ERROR* uncleared pch fifo underrun on pch transcoder A
i915 0000:00:02.0: [drm] *ERROR* PCH transcoder A FIFO underrun
b43 bcma0:1: firmware: failed to load b43/ucode30_mimo.fw (-2)
b43 bcma0:1: firmware: failed to load b43-open/ucode30_mimo.fw (2)
b43 bcma0:1: firmware: failed to load b43-open/ucode30_mimo.fw (2)

I remember I had to deal with Broadcom drivers a few years ago. Other than these errors, I can log in and everything seems to be fine.

sure :slight_smile: all fine

so now just to make sure,
you are able to log into the system and are able to type commands?

that’s by the way related to your wireless driver
firmware: failed to load b43/ucode30_mimo.fw (-2)

this one related to your graphic card,
i915 0000:00:02.0: [drm] ERROR uncleared fifo underrun on pipe A

for some reason your graphic card doesn’t works well without DXVK
so now for conclusion i will tell you what i think,
yunohost comes without any option to install the necessary desktop environments what will bring some important dependencies for your graphic card, which is a big problem,
its look like your model have some issues with linux which can be solved by installing desktop environment,

so there are two options here to my opinion:

  1. install yunohost on another computer, then install desktop environment on that computer, transfer back the disk to your laptop and see what happens,

  2. install desktop environment, then install yunohost on top of it with commands using repositories, which i am not sure if its possible @Aleks need to answer about this,

  3. maybe @Aleks have a better suggestion.

1 Like


I can indeeed log in and issue commands just fine. Thank you for getting me until here! :slight_smile:
I’m aware of problems with the wireless driver, fought with it back in the days as well.

Never had any issues with graphics though so thank you for your suggestions! I’ll wait for more feedback before proceeding with any of them.

In the meantime, according to ark, the i7-3520M has the HD Graphics 4000 graphics controller. Lscpi says its a 3rd Gen Core processor Graphics Controller (rev 9) to be exact. I thought I’d leave the information here in case anyone has the same problems or device.

just wait for @Aleks to reply, at the end if no one will provide any better suggestion so you can try the solution i offered with installing yunohost on another machine, which i think its not really necessary, i think there is a way to install yunohost on top of debian, i did never got deeper into it though,

1 Like

there’s a way to install yunohost on top of debian here it is:

if you face any issues don’t hesitate to ask

1 Like


Sorry for the silence. I set up my notifications wrong and didn’t receive alerts of a response. I tried the method of installing yunohost upon debian while not having anything to do and it worked flawlessly.

Everyhing’s perfect and I’m up and running again :heart:

Thank you for all the help and being patient. Wishing you a Merry Christmas and Happy new years! :blush:

1 Like

sure man marry Christmas, thanks, glad it helps,
i strongly recommend to backup your whole server to an image / ghost file so it will be easier for you to recover in a case of disaster, that can be achieve by installing a second Debian on the same machine with apart-gtk (make some research about it, its cool), or connect your ssd to another machine make an image and set the disk back,
yunohost backup is really good but sometimes an image can save you from a lot of troubles,

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.