Bludit - can it be hosted alongside yunohost on same machine?

I am looking for help installing the excellent Bludit (blogging CMS) to replace wordpress.

I don’t yet understand how to package it as mu knowledge of nginx is very minimal. The app is a index.php page that requires no database and works with nginx. Im thinkin it should be easy to set it up alonside yunohost so that I can just set a link to it.
It might actually be easy to package but I’m not sure about the server settings so I suspect it would be easier to set it up alongside yunohost and use redirect app within yunohost (im actually happy to use a link without yunohost, I just don’t know how to get it on the same machine so I can access it remotely… Any help much appreciated.

SOURCE: https://github.com/bludit/bludit
DOCUMENTATION: https://docs.bludit.com/en

Thanks

If you just want to install it for you, you should try to do it with the “Custom web app”, this app create an empty dir where you can install your CMS like on a mutu host…

If you really want to package the app, the better way is to watch how the example package works. https://github.com/YunoHost/example_ynh

Thank you. That looks promising. I’ve installed the ‘custom web app’ and I can see the default web page/app, the only thing I need to be able top do is figure out where that page’s files are stored so I can replace it with the bludit ones. I don’t know where any of the apps in yunohost are stored (I can see the json/manifest ones in etc/yunohost but not where the actual data / files are. Any ideas? Much appreciated.

/var/www/my_webapp/ (or something like this.

Ok thanks again I got that now. Unfortunately it only works for the home page of bludit. clicking on the admin link (or any other link from bludit) takes me back to ssowat. I guess I need to make an app for each bludit page individually, which wont be any use. Would this be an issue if I tried to make a yunohost app too? I’m not familiar with PHP sites.

No. Probably your cms has not the subpath configured ? If link redirected to the root it (could trigger the sso…

any idea how I can solve / find that subpath?

Maybe in a config file of your bluddit ?

I’ve tried looking, I can install Bludit in the webapp app, give the var/www/my_webapp all permissions etc, and I get the Bludit install screen and then the home screen. As soon as I try and get to admin it goes straight to ssowat. I don’t know where the admin panel is located. I assumed it was all in the var/www/my_webapp(blaudit) directory.

I would be grateful if anyone could take a look and see. Unfortunately I know nothing about php. Bludit is a really good blog app , flat files, and fast. I just don’t feel confident enough to package it up. If I could figure a way to get past to the admin panel and install as a custom web app I’d be happy. Yunohost is superb. Thanks for your help people.

Hello,
Your messages have aroused my curiosity!
I copied Bludit under /var/www/mywebapp/www/
Like you I managed to install it well but then I am systematically sent back to the Yunohost SSO as soon as I try to go to ./admin.
I tried to find out, but I’m not a PHP expert.
Maybe, tomorrow I will try this approach:


As for the packaging of this application for Yunohost, it is well beyond my, lean, skills :frowning:

Translated with www.DeepL.com/Translator

Please let me know if you have any luck. Its probably something simple to do with Bludits permisisons/links but I know nothing about PHP scripting and nginx knowledge is limited. You might have more luck following this link specific to Debian unstead of ubuntu.

I think issue may be something to do with this line:

Change the ownership of the /var/www/bludit directory to {your_user}:

sudo chown -R {your_user}:{your_user} /var/www/bludit

I’m not sure what to put in place of your_user and obviously /var/www/bludit needs to be var/www/mywebapp but perhaps budit php scripts expects this directory to be bludit not mywebapp so fails? Not sure.

Hello,
I found a way, it seems to me: after the installation there is an .htaccess of, among other things, “rewriting” which, in my humble opinion, has no effect on the functioning of Nginx.
It is certainly necessary to “translate” the .htaccess in the Nginx configuration.
But, all this is not very clean in the context of Yunohost :frowning:

Did you manage to get this to work without packaging it?

Hello,
I managed to make it work with this method :

PHP Built-in web server
You can run Bludit quickly via the command line and PHP Built-in web server.
$ git clone https://github.com/bludit/bludit.git
cd bludit
php -S localhost:8000
With your favorite browser, visit the URL http://localhost:8000

Then I tried, without success, with the redirect application of Yunohost.

Yes, unfortunately thats only for local access.

Hello,
Maybe one day, someone will go bludit package. It must be possible to do that.
I saw it on the whishlist, it’s a start.
The best thing is to do it yourself, but, as far as I’m concerned, I can’t (yet?):slight_smile:

Hi,
I don’t know if this will work for bludit but I had the same issue with custom web app + Wordpress migration (homepage ok but 404 error/white page/redirect for other pages).
I solved the issue by editing the conf file

nano /etc/nginx/conf.d/MY-DOMAIN.ORG.d/my_webapp__X.conf
# Original code
# 	Default indexes and catch-all
# 	index index.html index.php;
# 	try_files $uri $uri/ /index.php?$args;

# New code
    	index index.php;
   	 if (!-e $request_filename)
  	  {
          rewrite ^(.+)$ /index.php?q=$1 last;
   	 }

Then I restarted nginx

sudo yunohost service stop nginx
sudo yunohost service start nginx

It worked for all my Wordpress migrations and Drupal 8.

Bonjour,
J’ai testé hier, ça n’a pas fonctionné pour Bludit sur mon installation.
Dès que je serai à nouveau devant mon ordinosaure, je collerai, ici-même le contenu de mon fichier .htaccess pour essayer de trouver une "traduction’ Nginx.

Suite :
Bonjour,

Mon application Custom Webapp Yunohost est installée sous https://mondomaine.ltd/site :
Bludit est installée à la racine /var/www/mywebapp/www/

Le contenu du /var/www/mywebapp/www/.htaccess

AddDefaultCharset UTF-8
<IfModule mod_rewrite.c>
# Enable rewrite rules
RewriteEngine on
# Base directory
RewriteBase /site/
# Deny direct access to the next directories
RewriteRule ^bl-content/(databases|workspaces|pages|tmp)/.*$ - [R=404,L]
# All URL process by index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php [PT,L]
</IfModule>

Le contenu de /etc/nginx/conf.d/mondomaine.ltd.d/my_webapp.conf

rewrite ^/site$ /site/ permanent;
location /site/ {

    # Path to source
    alias /var/www/my_webapp/www/;

    # Force usage of https
    if ($scheme = http) {
        rewrite ^ https://$server_name$request_uri? permanent;
     }

    # Default indexes and catch-all
     index index.html index.php;
     try_files $uri $uri/ /site/index.php?$args;

    # Prevent useless logs
    location = /site/favicon.ico {
        log_not_found off;
        access_log off;
    }
    location = /site/robots.txt {
        allow all;
        log_not_found off;
        access_log off;
    }

    # Deny access to hidden files and directories
    location ~ ^/site/(.+/|)\.(?!well-known\/) {
        deny all;
    }

    # Execute and serve PHP files
    location ~ [^/]\.php(/|$) {
        fastcgi_split_path_info ^(.+?\.php)(/.*)$;
        fastcgi_pass unix:/var/run/php/php7.0-fpm-my_webapp.sock;
        fastcgi_index index.php;
        include fastcgi_params;
        fastcgi_param REMOTE_USER $remote_user;
        fastcgi_param PATH_INFO $fastcgi_path_info;
        fastcgi_param SCRIPT_FILENAME $request_filename;
    }
### End of PHP configuration part

    # Include SSOWAT user panel.
      include conf.d/yunohost_panel.conf.inc;
}

Bludit termine bien l’installation, mais le lien https://mondomaine.ltd/site/admin me renvoie au SSO Yunohost !

Je ne suis pas assez expert pour :
1- Packager cette application (mais ça vous l’aviez compris :slight_smile: )
2 - Paramétrer Nginx, même grace aux conseils suivants :
https://docs.bludit.com/en/webservers/nginx

A begging request: Is anyone able and willing to package this app for the community please? I am desperate to get this on a yunohost server, its such a good blogging CMS. I really don’t want to ditch yuno for docker and pay for hosting, I love yunohost and the philosophy of self hosting. Unfortunately i know very little coding, just don’t get php. I’ve been trying for days with no luck. I’m willing to donate money to the project if anyone can help?