Beta-testing phase for YunoHost 3.0 on Debian Stretch

fr
en

#163

J’ai fait une reinstall complète du yunohost.
Tout avait l’air de bien marcher jusqu’à ce que j’ajoute un nom de domaine et ça a l’air d’avoir tout bloquer à nouveau : est-ce que ça pourrait être le problème ou c’est juste une coincidence ?
Toujours la même erreur dans le yunohost-api.log…
C’est très frustrant :frowning:


#164

@Aleks une idée pour ma mise à jour Nextcloud ?


#165

@Limezy : je pense que tu peux aller dans /home/yunohost.backup/archives et supprimer (ou deplacer / renommer) un backup qui devrait s’appeler nextcloud-pre-upgrade1


#166

En effet, mais la suppression ne résoud pas mon problème


#167

Est-ce que tu peux verifier qu’avec un yunohost backup list, tu n’as effectivement plus d’archive qui s’apelle “nextcloud-pre-upgrade” (ou similaire) ?


#168

Non, j’ai la même liste qu’en faisant un ls dans /home/yunohost.backup/archives.
Pour être précis, je viens de m’apercevoir que l’erreur remontée a changé depuis que j’ai supprimé les anciens backup (désolé c’est à l’envers, je l’ai fait depuis l’administration web)

Impossible de mettre à jour nextcloud

Backup failed, the upgrade process was aborted.

The output directory is not empty

Mise à jour de l’application nextcloud…

Upgrading apps nextcloud


#169

Marf ben j’imagine que y’a un backup qui a été interrompu à un moment …

J’imagine que le repertoire /home/yunohost.backup/tmp n’est pas vide ?

Est-ce que mount | grep tmp renvoie un truc en rapport avec le backup ?


#170

Je regarde tes pistes. En attendant, j’ai fait un run en CLI avec l’option debug :

4749 DEBUG + current_version=13.0.0
4749 DEBUG + current_major_version=13
4749 DEBUG + ‘[’ 13 -gt 11 ‘]’
4749 DEBUG + ynh_app_setting_set nextcloud backup_core_only 1
4750 DEBUG + sudo yunohost app setting nextcloud backup_core_only --value=1 --quiet
5000 DEBUG + ynh_backup_before_upgrade
5001 DEBUG + ‘[’ ‘!’ -e /etc/yunohost/apps/nextcloud/scripts/backup ‘]’
5001 DEBUG + backup_number=1
5001 DEBUG + local old_backup_number=2
5002 DEBUG + local app_bck=nextcloud
5002 DEBUG + NO_BACKUP_UPGRADE=0
5002 DEBUG + ‘[’ 0 -eq 0 ‘]’
5003 DEBUG + grep -q nextcloud-pre-upgrade1
5004 DEBUG + sudo yunohost backup list
5277 DEBUG + sudo BACKUP_CORE_ONLY=1 yunohost backup create --apps nextcloud --name nextcloud-pre-upgrade1
5527 WARNING The output directory is not empty
5552 DEBUG + ‘[’ 5 -eq 0 ‘]’
5552 WARNING Backup failed, the upgrade process was aborted.
5553 DEBUG + ynh_die ‘Backup failed, the upgrade process was aborted.’
5556 DEBUG + echo ‘Backup failed, the upgrade process was aborted.’
5556 DEBUG + exit 1
5650 ERROR Unable to upgrade nextcloud
5651 DEBUG action [7595.1] executed in 5.428s
5651 DEBUG lock has been released
5651 ERROR No app to upgrade


#171

Bon, j’ai réussi à mettre à jour en supprimant les backups dans /tmp… mais maintenant je tombe sur une erreur 502 - BAD GATEWAY


#172

C’est pire que j’imaginais… Ça concerne toutes mes applis !
Hum… Visiblement mon php7.0-fpm n’arrive plus à redémarrer


#173

Bon là l’idéal c’est que tu passes sur le chat parce que ça sort quand meme pas mal du contexte de stretch et y’a a priori pas mal de choses à regarder…


#174

Bonjour,

j’essaye de passer à yunohost 3 mais j’ai une erreur :

Warning: Starting main upgrade ...
error: Cannot find a question for postgresql-common/obsolete-major
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lutim-ynh-deps : Depends: carton but it is not going to be installed
                  Depends: perlmagick
 mariadb-server : Depends: mariadb-server-10.0 (>= 10.0.32-0+deb8u1) but it is not going to be installed
 ssowat : Depends: nginx-extras (>= 1.6.2) but it is not going to be installed
 yunohost : Depends: git but it is not going to be installed
            Depends: slapd but it is not going to be installed
            Depends: postfix-policyd-spf-perl but it is not going to be installed
            Depends: nginx-extras (>= 1.6.2) but it is not going to be installed
            Recommends: libdbd-ldap-perl but it is not going to be installed
            Recommends: libnet-dns-perl but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Error: Migration 3 migrate_to_stretch has failed with exception Something wrong happened during the main upgrade : system is still on Jessie !? To investigate the issue, please look at /tmp/migrate_to_stretch.log :s ..., aborting
root@arnauld:~# 

J’avais il y a un mois, transféré yunohost sur un disque dur externe en ne gardant sur la carte SD du Pi que le boot.

Merci des conseils.


#175

Salut,

ça semble être le même problème que décrit ici : Migration stretch : dépendances non satisfaites

résolu en désinstallant lutim le temps de la migration (si lutim est déja désinstallé, tu peux forcer le truc avec “apt-get remove lutim-ynh-deps”)


#176

Merci Aleks, ça a l’air de marcher, je verrai le résultat demain, je vais dormir.


#177

Tout est cassé, je n’ai plus accès à rien, ni à l’interface ni en ssh…


#178

Je ne vois pas quoi te proposer d’autre qu’une réinstallation à neuf, sous stretch, en remettant ta sauvegarde. :’(


#179

Je suis de retour, je viens de modifier le packaging pour pouvoir installer (pas en mise à jour) mytinytodo sur la version 3.1.0 et php 7, pour le moment c’est en testing, vous devez utiliser le mode cli pour installer.

sudo yunohost app install https://github.com/YunoHost-Apps/mytinytodo_ynh/tree/testing --debug

J’attends vos retours.