Migration stretch : dépendances non satisfaites

,

Salut ! J’ai tenté une migration vers Stretch, mais qui a échoué. J’ai le message d’erreur suivant :

Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 lutim-ynh-deps : Dépend: carton mais ne sera pas installé
                  Dépend: perlmagick
 mailman : Dépend: apache2 mais ne sera pas installé ou
                    httpd
 ssowat : Dépend: nginx-extras (>= 1.6.2) mais ne sera pas installé
 yunohost : Dépend: git mais ne sera pas installé
            Dépend: mariadb-server mais ne sera pas installé ou
                     mysql-server mais ne sera pas installé
            Dépend: slapd mais ne sera pas installé
            Dépend: postfix-policyd-spf-perl mais ne sera pas installé
            Dépend: nginx-extras (>= 1.6.2) mais ne sera pas installé
            Recommande: libdbd-ldap-perl mais ne sera pas installé
            Recommande: libnet-dns-perl mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

En fouillant un peu, j’ai vu qu’on pouvait peut-être réparer ça avec un sudo apt -f, mais avant de tenter je voulais d’abord avoir un avis. Est-ce que ça peut être dû à des app qui ne sont pas prêtes pour la migration ?

1 Like

Salut,

je crois avoir vu quelqu’un récemment dans une situation similaire. Est-ce que tu aurais piwigo installé par hasard ? Il me semble que la solution était de désinstaller piwigo et de le réinstaller ensuite…

Salut,
J’ai pas piwigo. Les dépendances non satisfaites ont l’air de concerner lutim, mailman, ssowat et yunohost.
Si je fais un apt -f, ça va faire quoi exactement ? Installer les dépendances manquantes ? Est-ce que ça risque de casser quelque chose ?

Hello,
Idem pour moi voilà le retour que j’ai :

E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l’état.
Recommande: libnet-dns-perl mais ne sera pas installé
Recommande: libdbd-ldap-perl mais ne sera pas installé
Dépend: nginx-extras (>= 1.6.2) mais ne sera pas installé
Dépend: postfix-policyd-spf-perl mais ne sera pas installé
Dépend: slapd mais ne sera pas installé
mysql-server mais ne sera pas installé
Dépend: mariadb-server mais ne sera pas installé ou
yunohost : Dépend: git mais ne sera pas installé
ssowat : Dépend: nginx-extras (>= 1.6.2) mais ne sera pas installé
Dépend: perlmagick
lutim-ynh-deps : Dépend: carton mais ne sera pas installé
automake : Dépend: autoconf (>= 2.65) mais ne sera pas installé
Les paquets suivants contiennent des dépendances non satisfaites :

Vous avez une solution?
Merci les gars.

Maintenant j’ai un autre problème : quand je veux vérifier les mises à jour, que ce soit par l’interface web ou en ligne de commande :

admin@lamo:~$ sudo yunohost tools update
Traceback (most recent call last):
  File "/usr/bin/yunohost", line 219, in <module>
    timeout=opts.timeout,
  File "/usr/lib/python2.7/dist-packages/moulinette/__init__.py", line 136, in cli
    moulinette.run(args, output_as=output_as, password=password, timeout=timeout)
  File "/usr/lib/python2.7/dist-packages/moulinette/interfaces/cli.py", line 390, in run
    ret = self.actionsmap.process(args, timeout=timeout)
  File "/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py", line 498, in process
    return func(**arguments)
  File "/usr/lib/moulinette/yunohost/tools.py", line 430, in tools_update
    cache.upgrade(True)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 257, in upgrade
    self._depcache.upgrade(dist_upgrade)
SystemError: E:Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

Et j’ai tenté apt -f, qui ne donne rien :

admin@lamo:~$ sudo apt install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 941 non mis à jour.

Une idée ?

Aucune idée, mais j’ai exactement le même souci que toi.

Hmmmm ben sinon c’est peut-être lutim ? En tout cas j’ai l’impression que c’est perlmagick qui pose problème (et/ou imagemagick) …

Si vous avez la possibilité de désinstaller lutim ca peut ptete resoudre le probleme, meme si c’est pas très satisfaisant :confused:

J’ai déjà essayé, lutim n’est plus installé mais le problème demeure :frowning:

Hmmm, tu peux montrer ce qu’affiche le apt dist-upgrade dans ce cas ? (ou message équivalent pendant la migration, c.f. le premier post)

admin@ns3313695:~$ sudo apt dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Calcul de la mise à jour... Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 automake : Dépend: autoconf (>= 2.65) mais ne sera pas installé
 lutim-ynh-deps : Dépend: carton mais ne sera pas installé
                  Dépend: perlmagick
 ssowat : Dépend: nginx-extras (>= 1.6.2) mais ne sera pas installé
 yunohost : Dépend: git mais ne sera pas installé
            Dépend: mariadb-server mais ne sera pas installé ou
                     mysql-server mais ne sera pas installé
            Dépend: slapd mais ne sera pas installé
            Dépend: postfix-policyd-spf-perl mais ne sera pas installé
            Dépend: nginx-extras (>= 1.6.2) mais ne sera pas installé
            Recommande: libdbd-ldap-perl mais ne sera pas installé
            Recommande: libnet-dns-perl mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
admin@ns3313695:~$

C’est exactement comme @tomdereub ; je vois en effet une mention à lutim-ynh-deps ; un reste de quelque chose mal désinstallé ?

Arf oui on dirait … Tu peux tenter un apt remove lutim-ynh-deps ?

1 Like

Tout simplement :roll_eyes:
Merci beaucoup, cela a l’air de fonctionner pour le moment (migration en cours) :crossed_fingers:

Edit : tout s’est bien passé. Merci à nouveau @Aleks, ainsi qu’à toute l’équipe :+1:

1 Like

Ça a marché pour moi aussi, merci ! J’ai juste lutim qui marche plus après la migration, et je n’arrive pas à le réinstaller :

Attention : 2018-06-26 11:44:11 URL:https://framagit.org/luc/lutim/repository/0.10.4/archive.tar.gz [3232719/3232719] -> "app.tar.gz" [1]
Attention : W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://dl.yarnpkg.com/debian stable InRelease: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY E074D16EB6FF4DE3
Attention : W: Impossible de récupérer https://dl.yarnpkg.com/debian/dists/stable/InRelease  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY E074D16EB6FF4DE3
Attention : W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
Attention : E: Les paquets doivent être enlevés mais la désinstallation est désactivée.
Attention : Unable to install dependencies
Attention : !!
Attention :   lutim's script has encountered an error. Its execution was cancelled.
Attention : !!
Attention :
Attention : Failed to get status information via dbus for service sickgear, systemctl didn't recognize this service ('NoSuchUnit').
Attention : etckeeper warning: hardlinked files could cause problems with git:
Attention : nginx/conf.d/liste.plaf.fr.d/mailman.conf
Attention : /etc/nginx/conf.d/plaf.fr.d/lutim.conf wasn't deleted because it doesn't exist.
Attention : /etc/cron.d/lutim wasn't deleted because it doesn't exist.
Succès ! La configuration de SSOwat a été générée
Erreur : Échec de l'installation

Et j’ai toujours un bug sur les mises à jour sur l’interface admin :

Action

PUT /update
 {"locale":"fr"}

Trace

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/moulinette/interfaces/api.py", line 406, in process
    ret = self.actionsmap.process(arguments, timeout=30, route=_route)
  File "/usr/lib/python2.7/dist-packages/moulinette/actionsmap.py", line 498, in process
    return func(**arguments)
  File "/usr/lib/moulinette/yunohost/tools.py", line 428, in tools_update
    if not cache.update():
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 466, in update
    raise FetchFailedException()
FetchFailedException

Est-ce que si tu refais un “apt-get dist-upgrade” il essaye d’installer des paquets ou autre ?

Oui j’ai déjà essayé, ça a installé quelques paquets et supprimé d’autres, mais ça n’a pas réglé le problème. Si je le refais :

admin@lamo:~$ sudo apt dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  imagemagick-common libarchive13 php5-curl php5-intl php5-ldap php5-mcrypt php5-redis smbclient ttf-dejavu-core
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

A mon avis, tu peux faire un apt autoremove et retenter l’installation

Voici ce que ça donne :

admin@lamo:~$ sudo apt autoremove
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  imagemagick-common libarchive13 php5-curl php5-intl php5-ldap php5-mcrypt php5-redis smbclient ttf-dejavu-core
0 mis à jour, 0 nouvellement installés, 9 à enlever et 0 non mis à jour.
Après cette opération, 3 571 ko d'espace disque seront libérés.

Tout s’est à priori désinstallé correctement, par contre ça règle pas mon bug pour les mises à jour dans l’interface admin.

je confirme, lutim et lutim-ynh-deps bloquent la migration,
une fois yunohost app remove lutim && apt remove lutim-ynh-deps effectué, la migration se lance correctement (c’est en cours, j’espère qu’elle ira bien au bout)

1 Like

migration terminée, quelques effets de bords (lutim KO j’arrive pas à le réinstaller, update/upgrade KO ticket ouvert sur https://github.com/YunoHost/issues/issues/1155 )

ticket ouvert sur https://github.com/YunoHost-Apps/lutim_ynh/issues/26 pour le soucis de Lutim ,
merci d’alimenter le ticket si d’autres rencontrent également le soucis, sinon il sera clos sans que l’on sache si ça venait bien de Lutim ou pas