Beta-testing phase for YunoHost 3.0 on Debian Stretch

fr
en

#22

Maha oui pas faux
heu … fini ?


#23
~# systemctl status fail2ban 
● fail2ban.service - Fail2Ban Service
   Loaded: loaded (/lib/systemd/system/fail2ban.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-05-09 01:03:01 CEST; 16min ago
     Docs: man:fail2ban(1)
 Main PID: 24943 (fail2ban-server)
      CPU: 15.297s
   CGroup: /system.slice/fail2ban.service
           └─24943 /usr/bin/python3 /usr/bin/fail2ban-server -s /var/run/fail2ban/fail2ban.sock -p /var/run/fail2ban/fail2ban.pid -x -b

May 09 01:02:58 tata.fr systemd[1]: Starting Fail2Ban Service...
May 09 01:02:59 tata.fr fail2ban-client[24940]: 2018-05-09 01:02:59,978 fail2ban.server         [24941]: INFO    Starting Fail2ban v0.9.6
May 09 01:02:59 tata.fr fail2ban-client[24940]: 2018-05-09 01:02:59,979 fail2ban.server         [24941]: INFO    Starting in daemon mode
May 09 01:03:01 tata.fr systemd[1]: Started Fail2Ban Service.

\o/


#24

\o/

Je vais pousser des fixs pour régler les soucis que tu as rencontré du coup. Merci d’avoir pris le temps !

(Ceci dit maintenant il faut voir si toutes les apps fonctionnent toujours, c’est une autre affaire :stuck_out_tongue:)


#25

De rien.

Après de rapides test seul nextcloud semble avoir un pb. Les autres fonctionnent( Shaarli, Wallabag, Gog, dokuwiki)

Concernant Nextcloud, j’aime pas trop ce que je vois :

mon site-log-error:

2018/05/09 00:32:06 [error] 5624#5624: *127 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught exception 'Doctrine\DBAL\DBALException' with message 'Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)' in /var/www/nextcloud/lib/private/DB/Connection.php:64
Stack trace:
#0 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /var/www/nextcloud/lib/private/DB/Connection.php(151): Doctrine\DBAL\Connection->setTransactionIsolation(2)
#5 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doct...
PHP message: PHP Fatal error:  Uncaught exception 'Doctrine\DBAL\DBALException' with message 'Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)' in /var/www/nextcloud/lib/private/DB/Connection.php:64
Stack trace:
#0 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /var/www/nextcloud/lib/private/DB/Connection.php(151): Doctrine\DBAL\Connection->setTransaction
2018/05/09 00:32:38 [error] 5622#5622: *229 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught exception 'Doctrine\DBAL\DBALException' with message 'Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)' in /var/www/nextcloud/lib/private/DB/Connection.php:64
Stack trace:
#0 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /var/www/nextcloud/lib/private/DB/Connection.php(151): Doctrine\DBAL\Connection->setTransactionIsolation(2)
#5 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doct...
PHP message: PHP Fatal error:  Uncaught exception 'Doctrine\DBAL\DBALException' with message 'Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)' in /var/www/nextcloud/lib/private/DB/Connection.php:64
Stack trace:
#0 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /var/www/nextcloud/lib/private/DB/Connection.php(151): Doctrine\DBAL\Connection->setTransaction
2018/05/09 00:33:10 [error] 5622#5622: *231 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught exception 'Doctrine\DBAL\DBALException' with message 'Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)' in /var/www/nextcloud/lib/private/DB/Connection.php:64
Stack trace:
#0 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /var/www/nextcloud/lib/private/DB/Connection.php(151): Doctrine\DBAL\Connection->setTransactionIsolation(2)
#5 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doct...
PHP message: PHP Fatal error:  Uncaught exception 'Doctrine\DBAL\DBALException' with message 'Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)' in /var/www/nextcloud/lib/private/DB/Connection.php:64
Stack trace:
#0 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): Doctrine\DBAL\Connection->getDatabasePlatform()
#jounalctl -xe  
May 09 01:33:55 tata.fr sshd[25909]: Unable to negotiate with 176.31.45.48 port 47398: no matching MAC found. Their offer: hmac-sha1,hmac-sha1-96,hmac-md5,hmac-md5-96,hmac-ripemd160,hmac-ripemd160@openssh.
...skipping...
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr slapd[5341]: <= mdb_equality_candidates: (gidNumber) not indexed
May 09 01:30:03 tata.fr slapd[5341]: <= mdb_equality_candidates: (uniqueMember) not indexed
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:03 tata.fr mysqld[10878]: 2018-05-09 01:30:03 7f9c9dbea700 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (ty
May 09 01:30:04 tata.fr CRON[25854]: pam_unix(cron:session): session closed for user nextcloud
May 09 01:31:15 tata.fr nslcd[28672]: [f2b15e] <passwd="*"> request denied by validnames option
May 09 01:31:42 tata.fr sshd[25892]: rexec line 19: Deprecated option KeyRegenerationInterval
May 09 01:31:42 tata.fr sshd[25892]: rexec line 20: Deprecated option ServerKeyBits
May 09 01:31:42 tata.fr sshd[25892]: rexec line 32: Deprecated option RSAAuthentication
May 09 01:31:42 tata.fr sshd[25892]: rexec line 39: Deprecated option RhostsRSAAuthentication
May 09 01:31:42 tata.fr sshd[25892]: Unable to negotiate with 176.31.45.48 port 50966: no matching MAC found. Their offer: hmac-sha1,hmac-sha1-96,hmac-md5,hmac-md5-96,hmac-ripemd160,hmac-ripemd160@openssh.
May 09 01:31:53 tata.fr postfix/anvil[25840]: statistics: max connection rate 1/60s for (smtp:103.109.75.2) at May  9 01:28:32
May 09 01:31:53 tata.fr postfix/anvil[25840]: statistics: max connection count 1 for (smtp:103.109.75.2) at May  9 01:28:32
May 09 01:31:53 tata.fr postfix/anvil[25840]: statistics: max cache size 1 at May  9 01:28:32
May 09 01:32:08 tata.fr sshd[25895]: rexec line 19: Deprecated option KeyRegenerationInterval
May 09 01:32:08 tata.fr sshd[25895]: rexec line 20: Deprecated option ServerKeyBits
May 09 01:32:08 tata.fr sshd[25895]: rexec line 32: Deprecated option RSAAuthentication
May 09 01:32:08 tata.fr sshd[25895]: rexec line 39: Deprecated option RhostsRSAAuthentication
May 09 01:32:08 tata.fr sshd[25895]: reprocess config line 32: Deprecated option RSAAuthentication
May 09 01:32:08 tata.fr sshd[25895]: reprocess config line 39: Deprecated option RhostsRSAAuthentication
May 09 01:32:08 tata.fr sshd[25895]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=164.132.160.178  user=redis
May 09 01:32:10 tata.fr sshd[25895]: Failed password for redis from 164.132.160.178 port 53787 ssh2
May 09 01:32:10 tata.fr sshd[25895]: Connection closed by 164.132.160.178 port 53787 [preauth]
May 09 01:32:16 tata.fr sshd[25898]: rexec line 19: Deprecated option KeyRegenerationInterval
May 09 01:32:16 tata.fr sshd[25898]: rexec line 20: Deprecated option ServerKeyBits
May 09 01:32:16 tata.fr sshd[25898]: rexec line 32: Deprecated option RSAAuthentication
May 09 01:32:16 tata.fr sshd[25898]: rexec line 39: Deprecated option RhostsRSAAuthentication
May 09 01:32:18 tata.fr sshd[25898]: reprocess config line 32: Deprecated option RSAAuthentication
May 09 01:32:18 tata.fr sshd[25898]: reprocess config line 39: Deprecated option RhostsRSAAuthentication
May 09 01:32:19 tata.fr sshd[25898]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=166.78.22.228  user=root
May 09 01:32:20 tata.fr sshd[25898]: Failed password for root from 166.78.22.228 port 9224 ssh2
May 09 01:32:20 tata.fr sshd[25898]: Connection closed by 166.78.22.228 port 9224 [preauth]
May 09 01:33:01 tata.fr CRON[25903]: pam_unix(cron:session): session opened for user root by (uid=0)
May 09 01:33:01 tata.fr CRON[25904]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
May 09 01:33:01 tata.fr CRON[25903]: pam_unix(cron:session): session closed for user root
May 09 01:33:55 tata.fr sshd[25909]: rexec line 19: Deprecated option KeyRegenerationInterval
May 09 01:33:55 tata.fr sshd[25909]: rexec line 20: Deprecated option ServerKeyBits
May 09 01:33:55 tata.fr sshd[25909]: rexec line 32: Deprecated option RSAAuthentication
May 09 01:33:55 tata.fr sshd[25909]: rexec line 39: Deprecated option RhostsRSAAuthentication
May 09 01:33:55 tata.fr sshd[25909]: Unable to negotiate with 176.31.45.48 port 47398: no matching MAC found. Their offer: hmac-sha1,hmac-sha1-96,hmac-md5,hmac-md5-96,hmac-ripemd160,hmac-ripemd160@openssh.

#26

Là j’ai moins de solution magique :s

Est-ce que tu peux vérifier que le service mysql est bien actif ?


#27

oui, c’est actif.


#28

bon je regarderai ça plus tard (mes pb mysql/nextcloud et sshd), dodo.
++ merci pour l’aide


#29

Hello,
I’m a new comer in Raspberry world.
I wanted to install a server from “fresh installation and pre-installed Raspberry Pi image”, here my experience…

I downloaded Pre-install Raspberry Pi image (yunohost-stretch-3.0.0~beta1.1-rpi-testing.zip)
Flash it with Etcher

boot server
connecting root
launch 'yunohost tools postinstall'

I restart on login session! (no GUI)

so, connect root
launch 'raspi-config'
-> configure locale for French environment (localization, keyboard, wifi, timezone)
-> configure boot  option for starting on graphic interface 
	=> message "you should launch  sudo apt-get install lighdm"

So, I launch 'apt-get install lighdm --fix-missing' (without '--fix-missing', you should previously launch 'apt-get update')

launch 'raspi-config'
-> configure boot option , B1 Desktop / CLI, B3 Desktop
reboot

I get desktop, try to login with 'admin' account => Unsuccess!
The screen become black, then after few seconds, I come back to the login screen...

The same with 'root' account...

HELP! Please!

I also tried by installing (on another SD Card) a server with NOOBS 2.8.1 (Raspbian Stretch, then) + command ‘bash <(wget -q -O- https://install.yunohost.org/stretch)’
It run better.
But NextCloud do not install …
But I saw that there is currently some ongoing update on these points (thanks in advance to gannonwoto and Aleks for their actions) :slight_smile:

PS: Je m’efforce d’écrire en anglais pour être compris du plus grand nombre possible. Si c’est pas utile, merci de me le préciser, je préfère tout de même ma langue maternelle… :wink:


#30

Mise à jour d’une Debian 8 à jour via la commande

yunohost tools migration migrate --accept-disclaimer

Ca finit en

Attention : application de la migration 4 php5_to_php7_pools
Erreur : la migration 4 php5_to_php7_pools a échoué avec l’exception [Errno 22]
Service " pho7.0-fpm " inconnu, annulation

La version de debian est bien montée en 9

cat /etc/debian_version
9.4

Je regarde si je trouve des logs pertinents.

Update

nginx -t
nginx: [emerg] unknown directive “access_by_lua_file” in /etc/nginx/conf.d/toto.org.conf:6
nginx: configuration file /etc/nginx/nginx.conf test failed

Et effectivement j’ai bien

more toto.org.conf
server {
listen 80;
listen [::]:80;
server_name toto.org.org;

access_by_lua_file /usr/share/ssowat/access.lua;

include conf.d/toto.org.d/*.conf;

location /yunohost/admin {
return 301 https://$http_host$request_uri;
}

access_log /var/log/nginx/toto.org-access.log;
error_log /var/log/nginx/toto.org-error.log;
}


#31

Tu peux écrire en français si tu veux oui :wink:

Mais du coup, je ne comprends pas pourquoi tu lancé raspi-config pour installer un desktop ? Apriori pour un serveur tu n’as pas besoin d’interface graphique :confused:

Si la postinstallation s’est bien passée, alors il n’y avait rien de spécial à faire, si ce n’est utiliser ton serveur “normalement”, par exemple en installant des apps, soit via la ligne de commande (yunohost app install --help) soit via la webadmin accessible via ton ip locale, ou ton nom de domaine si tu l’a bien configuré…?


#32

Hm c’est chelou :confused: Tu as moyen de vérifier quelle version de nginx est installée ? Tu devrais aussi avoir le paquet “nginx-extras” installé …

# dpkg --list | grep " nginx"
ii  nginx-common                          1.10.3-1+deb9u1
ii  nginx-extras                          1.10.3-1+deb9u1

#33

ii nginx-common 1.10.3-1+deb9u1
ii nginx-extras 1.10.3-1+deb9u1

Ce sont bien ces versions. Le soucis est sur nginx-extras que je n’arrive à pas à installer ou résintaller (problème avec des commandes du genre dkpg reconfigure…) Je vais creuser.
La machine est une VM, clone de ma production, pour pouvoir tout casser sans soucis avant de faire la vraie mise en production :wink:


#34

Je viens de faire la mise à jour depuis un serveur existant et j’ai une erreur similaire à celle de @genma.
Dans mon cas nginx-extras n’arrive pas à s’installer et provoque une réaction en chaine : les paquets qui en dépendent ne s’installent pas non plus.

Log de migration complet: https://framadrop.org/r/41RRu8Roqu#Stbt59GSiuObZJGn1dsQ3n2OR0XpaxF9x0vvBS5n834=

J’ai essayé d’installer nginx-extras avec apt, les logs (qui décrivent le soucis expliqué plus haut) : https://paste.yunohost.org/maciyapesi.vbs


#35

Erf ben là tout de suite je comprends vraiment pas :confused: J’ai bien la même version de nginx et il ne râle pas à cause de access_by_lua_file, qui est a priori une directive tout ce qu’il y a de plus légitime o.O

J’va râflâchir :confused:


#36

On dirait que rien ne fonctionne avec Lua. J’ai commenté toutes les directives access_by_lua_file et redémarré nginx, il me dit :

nginx: [emerg] unknown directive "lua_shared_dict" in /etc/nginx/conf.d/ssowat.conf:1


#37

Est-ce que tu as bien la même chose pour cette commande ?

# nginx -V 2>&1 | sed -e 's@--@\n--@g' | grep lua
--add-dynamic-module=/build/nginx-0ec7lA/nginx-1.10.3/debian/modules/nginx-lua

#38

J’ai

--add-dynamic-module=/build/nginx-2tpxfc/nginx-1.10.3/debian/modules/nginx-lua

Pas très différent…


#39

Et si on fait un dpkg --list | grep lua, est-ce que les versions correspondent (grosso-modo) ?

ii  liblua5.1-0:amd64        5.1.5-8.1+b2          
ii  libluajit-5.1-2:amd64    2.0.4+dfsg-1+b1       
ii  libluajit-5.1-common     2.0.4+dfsg-1          
ii  libnginx-mod-http-lua    1.10.3-1+deb9u1       
ii  lua-bitop:amd64          1.0.2-4               
ii  lua-event:amd64          0.4.3-2               
ii  lua-expat:amd64          1.3.0-4               
ii  lua-filesystem:amd64     1.6.3-1               
ii  lua-json                 1.3.3-2               
ii  lua-ldap:amd64           1.1.0-1-geeac494-6+b2 
ii  lua-lpeg:amd64           1.0.0-1               
ii  lua-rex-pcre:amd64       2.7.2-4               
ii  lua-sec:amd64            0.6-3                 
ii  lua-socket:amd64         3.0~rc1+git+ac3201d-3 
ii  lua-zlib:amd64           0.2+git+1+9622739-2+b2
ii  lua5.1                   5.1.5-8.1+b2

#40

Grosso modo oui, sauf que j’ai liblua5.2-0 installé en plus!

ii  liblua5.1-0:amd64                            5.1.5-8.1+b2                       amd64        Shared library for the Lua interpreter version 5.1
ii  liblua5.2-0:amd64                            5.2.4-1.1+b2                       amd64        Shared library for the Lua interpreter version 5.2

#41

Hmyep, je l’ai aussi sur d’autres instances stretch qui marchent :sweat_smile:

J’ai vraiment du mal à piger ce qui passe pas :confused: J’ai pas l’impression qu’il y ai d’histoire de backports ou quoi (de toute façon c’est la même version pour nginx-extras visiblement)

Eventuellement un reboot magique, mais c’est pas très satisfaisant é_è