Bazarr service won't start

Yo !

Bazarr does not want to start since server restarted after a power loss.
Tried restoring it from last preupgrade save but it did not change anything.
Not sure what happened here…

Here are some logs :

Bazarr starting...
2022-03-07 22:42:51,453 - root                             (7f3b71054740) :  INFO (driver:121) - Generating grammar tables from /usr/lib/python3.7/lib2to3/Grammar.txt
2022-03-07 22:42:51,503 - root                             (7f3b71054740) :  INFO (driver:121) - Generating grammar tables from /usr/lib/python3.7/lib2to3/PatternGrammar.txt
Traceback (most recent call last):
  File "bazarr/", line 31, in <module>
    from get_series import *
  File "/opt/yunohost/bazarr/bazarr/", line 12, in <module>
    from get_episodes import sync_episodes
  File "/opt/yunohost/bazarr/bazarr/", line 12, in <module>
    from get_subtitle import episode_download_subtitles
  File "/opt/yunohost/bazarr/bazarr/", line 43, in <module>
    from analytics import track_event
  File "/opt/yunohost/bazarr/bazarr/", line 18, in <module>
    radarr_version = get_radarr_info.version()
  File "/opt/yunohost/bazarr/bazarr/", line 321, in version
    radarr_version = requests.get(rv, timeout=60, verify=False, headers=headers).json()['version']
  File "/opt/yunohost/bazarr/bazarr/../libs/requests/", line 900, in json
    return complexjson.loads(self.text, **kwargs)
  File "/usr/lib/python3.7/json/", line 348, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.7/json/", line 337, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.7/json/", line 355, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)
Bazarr exited.

Bazarr cannot get Radarr’s version. Either Radarr is down, or Bazarr is misconfigured. Try disabling Radarr integration with use_radarr = False in /opt/yunohost/bazarr/config.ini. Then restart Bazarr’s service and check your settings again.

Radarr is up and running so i guess Bazarr is faulty there, but the closest file from .../config.ini i could find was /opt/yunohost/bazarr/bazarr/ in which default settings are stored and every integration is disabled.

OK nevermind i found it : it is /opt/yunohost/bazarr/data/config/config.ini

And it worked ! the API key must have been changed through the last radarr update and rebooting the server lost bazarr… Thanks !

As i downgraded bazarr when restoring it from pre upgrade save, i reupdated it and it broke again. After doing the same thing you advised it came back up but the update process seems to break the API links and bazarr gets lost… Might be a little bug there :wink:

Definitely! I’ll have a look into the code. :sweat_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.