Baïkal et agendav



je rencontre des problèmes pour faire fonctionner agendav et davdroid sur mon serveur baikal. Avec thunderbird, pas de soucis, je peux ajouter des évènements et ils s’incrémentent dans l’admin de baïkal.

  • agendav : l’écran d’accueil affiche à l’ouverture " Nom d’utilisateur ou mot de passe invalide " puis, quand je rentre les infos d’id et que je valide, une erreur survient : "CSRF id not present ".

Edit : c’est bon pour davdroid, en fait ça fonctionnait…Reste l’erreur agendav

serveur orangepipc sous armbian, yunohost 2.4


My French is not very good, but it seems we have the same problem: What is the Agendav login?

Not really. Or maybe we have, but from what you are saying it seems that you dont know which credentials you need to log in agendav. From what i understand, you first have to install and run a caldav-cardav server (baïkal or radicale) and sign in in agendav with the user you created upon server configuration (for baïkal). That’s where i m stuck with the “CSRF id not present” error.

I also have Baikal running. I can access it from both Thunderbird and Davdroid on Android.
But when I open AgenDAV I get a Invalid username or password, no matter what credentials I try (SSO/Baikal).

Ok. I tried to remove agendav from sso with sudo yunohost app setting agendav skipped_uris -v "/" followed by sudo yunohost app ssowatconf (sudo yunohost app setting agendav protected_uris -v "/" to put it back) and i got rid of the “Invalid username or password” message at launch. Unfortunately, i still have the csrf id not present.

Dubwise sorry but i dont have other idea except wrong credentials. Maybe you should try the sso stuff ?

I have tried as well yesterday, with the same disappointing results. I can relate to Dubwise as Baïkal is well and running and fully accessible ; unlike Agendav where I have litteraly tried every credential possible (including the automatically generated ones).

Y’as-t-il une raison pour lasquel tu n’utilises pas Baikal pour les agendas?
J’ai Baikal sur le serveur, il gere très bien le calendrier DAVdroid du téléphone.

A tu un certificat?

comme mentionné dans le 1er message, j’utilise baïkal comme serveur caldav, parfaitement fonctionnel sur des clients thunderbird ou davdroid. C’est le client agendav qui ne fonctionne pas. Et oui, j’ai let’s encrypt.

In the meantime I’ve switched to a fresh Yunohost 2.7.2 installation, but I’m still having issues with Baikal + Agendav. Baikal is working fine (I use it with Thunderbird and Davdroid), but Agendav is presenting me with a login screen and Invalid username or password. Whatever credentials I try (Baikal, Yunohost), I cannot get into Agendav. Any ideas?

I’ve finally found a solution: I had set the WebDAV authentication type in Baikal to Digest, as per (now updated). After switching it back to LDAP-UserBind, AgenDAV started to work. I also had to switch credentials in Thunderbird and DavDroid, from Baikal’s to Yunohost’s.

Great to hear that you made it working ! As for myself, i just entirely gave up on agendav. Maybe i will try again since you provided the solution. Thanks for the input !