Backup (+webadmin) not accessible anymore


#1

My YunoHost server

Hardware: VPS Kimsufi KS4
YunoHost version: (don’t know, can’t access admin area)

Description of my problem

  • Can’t access backup area on webadmin, after I click Local backup it’s just loading forever
  • On Shell In A Box, the command yunohost backup list won’t return anything. It seems to be loading endlessly.
  • Right now, as often, the webadmin is not accessible anymore. It’s loading endlessly. Maybe this is related? Anyway, the webadmin area always needs long loading time on my server. Can I do something about it?

Thanks a lot for your help!


#2

Your yunohost might be upgrading (only one yunohost command at a time…).
To check that

ps aux | grep yunohost

#3

Thanks for your help,

root       469  0.0  0.0  12780   924 pts/0    S+   11:38   0:00 grep yunohost                                                                 
avahi      652  0.0  0.0  38704  2280 ?        Ss   Apr13   0:00 avahi-daemon: running [yunohost.local]                                        
root       677  3.4  2.5 548520 103852 ?       Ssl  Apr13  90:17 /usr/bin/python /usr/bin/yunohost-api                                         

webadmin is back, but I can’t access to my backup area. Nor in webadmin or in shellinabox.


#4

You might have a bad archives that breaks all the things:

ls /home/yunohost.backup/archives

You can use --debug option when you list to see, where it runs indefinitely.

yunohost backup list --debug

#5

That should be right, can I empty the folder /home/yunohost.backup/without risk?


#6

You can empty /home/yunohost.backup/archives without risk


#7

Solved it, thanks.


#8

Not solved after all!
I did empty all my backups and did another one with the webadmin.
On the admin, all goes well, until the message “Backup completed”, then it’s still loading indefinitely.
After that, I can’t access to the webadmin area.

  • So now webadmin is not accessible (load indefinitely)
  • Thanks for any help!

Here is the result of

ps aux | grep yunohost
yunohost backup list --debug

(sorry for the pictures, can’t copy text out of Shell in a box)


#9

Well uh, idk, can you try pkill -9 yunohost ?


#10

Thanks @Aleks
Actually I did a reboot because I needed to get access back.
Now I’m trying to find Why when I run a backup, it mess everything up.

  • Could you tell me how I can see an hitory of the log that appear on the top of the screen in the webadmin? Can’t find it.

#11

Uuuh I think what you’re looking for is in Tools > Logs (or from the CLI, yunohost log list then yunohost log display <the_log_id>)