Backup restore - Error: Invalid password


I broke my instance. MySQL did not start anymore and I tried to apt-get remove/install it, which obviously was a bad idea. I’m trying to restore a backup.

yunohost backup restore 20190209-231002 
Info: Installing YunoHost…
Info: The operation 'Postinstall your YunoHost server' has failed! To get help, please share the full log of this operation using the command 'yunohost log display --share'
Error: Invalid password

Since Yunohost is not restored, the log display command does not work.

I supposed it might be the MySQL password. I reset it to default password but I’m still having the same error message.

Is there anyway I can restore my backup ?

I think this actually refers to the admin password and is a bug that was fixed in 3.4 …

But I doubt that restoring a backup will really fix your issue with mysql ? (YunoHost backup are not designed for this, they only store data and configuration of apps, conf, user data and other things but not system files)

Thanks @Aleks. I managed to restore mysql, drop databases and reset default mysql password.

I tried different commands to reset my Yunohost instance. After a lot of attempts I finally managed to restore the Yunohost backup. It works again.

After this restore action I still have a problem with dyndns., the answer might be in this thread. I’ll check this one tonight.

Cron <root@xxx> yunohost dyndns update >> /dev/null
No domain has been registered with DynDNS