Back up data from Cryptpad

I have searched the forum for similar issues

on

This category is for issues regarding specific apps, NOT general issues with YunoHost.

on

This form is written in English but feel free to write in French if you’re more comfortable!

on

What app is this about, and its version

Cryptpad, latest

What YunoHost version are you running

Latest

What type of hardware are you using

VPS bought online

Describe your issue

My cryptpad server does not work well. When opened it just stays at “Loading…”

I think the solution might be to make a fresh install, but in that case, I need to make a back up of the user files and reinsert them afterwards.

Is there an easy and safe way to do that?

Share relevant logs or error messages

Did you try the yunohost backup command?

No, and it is very embarrassing that I didn’t even notice that there is such a function!
There is indeed a backup file for the cryptpad instance, but I fear it was created after I messed thing up. But I will try (it cannot get worse, I hope)

OK, I tried, but to no avail.

Downloading the backup file fails and restoring it gives: “The following apps can't be restored because they are already installed: cryptpad

Try running chown -R cryptpad:www-data /var/www/cryptpad
Then restart the service systemctl restart cryptpad
And see if it helps.

Unfortunately not

Can you share the generated link
yunohost service log cryptpad | yunopaste

What does return ls -la /var/www/cryptpad/customize ?

# ls -la /var/www/cryptpad/customize
total 12
drwxr-x— 3 cryptpad www-data 4096 May 21 05:06 .
drwxr-x— 19 cryptpad www-data 4096 Sep 15 04:05 ..
drwxr-x— 25 cryptpad www-data 4096 Sep 15 04:06 www

Does that help?

Does your cryptpad domain match the domain set in /var/www/cryptpad/config/config.js ?

Does it comes after an upgrade ?

Did you have a sandbox-cryptpad.domain.tld or sandbox.cryptpad.domain.tld created ? and also have declared this one as a CNAME on DNS zone ?

Did you try force regenerate the ssl certificate for the cryptpad domain ?

This happened after this Error: "500" Handling: "GET /yunohost/api/domains

Yes

I found out that cryptpad provides this:

Diagnostics

CryptPad provides a diagnostics page that runs instance configuration tests. Visit https://cryptpad.yourdomain.com/checkup/ after completing all of the steps above to ensure everything is correctly configured.

But when trying at https://pad.jacobbahn.dk/checkup/ I just get:

Oops!

It’s possible that required resource couldn’t be loaded. See your browser’s console for more details.

Failed to load https://pad.jacobbahn.dk/customize/lucide.js?ver=2026.5.1-1789479497946.

Could this be helpful in any way?

I have made tar files of the folders I wish to copy before a fresh install and put them in /tmp on the Yunohost server:

But I cannot see them in FileZilla (note that I have changed the permission for the first tar)

I ran a diagnosis on the Yunohost server. It is generally fine but gives me these two issues:

Could that be related?

Once again I find that the answer for me is to start all over. I shut down this whole Yunohost server and will make a fresh install

I am really thankful for your efforts, though.