Automad and WonderCMS not actually public?

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 11.2.12
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | … all the above
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no special context
If yes, please explain:
If your request is related to an app, specify its name and version: WonderCMS version: 3.4.3~ynh1; and Automad version: 1.10.9~ynh5

Description of my issue

Hi folks!
I’m looking at blogging apps now -
I tried two: Automad and WonderCMS, but neither one allows a public view of themselves, even though I set them as public. If I navigate to my site from a public IP, I see this:

so a “visitor” has to log in? How do I fix this to make it truly public?

Here’s the settings on the app:

Screenshot_2024-06-08_20-55-38

Thanks for any help on this!