Apt aborts with "Illegal Instruction"

Hi all!

I am glad to have found a) YonoHost and b) this forum. What an awesome project! Still, I managed to break something, and so I’ll do my best to fill out this form.

My YunoHost server

Hardware: RasPi 2
YunoHost version: (stable)
I have access to my server : ssh and webbrowser
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes, minor tweak: I additionally installed cups though apt install cups
If yes, please explain: see above

Description of my issue

Unfortunately, i can’t really tell when it appeared the first time or what I did previously, but now, every time I try to upgrade/update/install anything through apt or the bulit-in YunoHost mechanism, all looks fine up to the point when actual installation should take place and then it aborts with “Illegal Instruction”. YunoPaste is below.
I did try apt clean, apt install --fix-broken and all that – no avail. Any ideas?

NB: we prefer you to share the full logs by clicking the green buttons “Share logs with YunoPaste”.
You can also copy them into paste.yunohost.org or directly include error messages using backticks like this :

  apps: false
  system: false
  target: system
ended_at: 2022-03-19 18:07:44.841481
error: Konnte nicht alle Pakete aktualisieren
interface: api
operation: tools_upgrade
parent: null
related_to: []
started_at: 2022-03-19 18:07:25.483514
success: false


2022-03-19 18:07:25,530: INFO - Momentan werden Upgrades für das System (YunoHost-unabhängige) Pakete durchgeführt...
2022-03-19 18:07:26,976: DEBUG - Running apt command :
DEBIAN_FRONTEND=noninteractive APT_LISTCHANGES_FRONTEND=none apt-get --fix-broken --show-upgraded --assume-yes --quiet -o=Dpkg::Use-Pty=0 -o Dpkg::Options::="--force-confold" -o Dpkg::Options::="--force-confmiss" -o Dpkg::Options::="--force-confdef" dist-upgrade
2022-03-19 18:07:27,250: INFO - + Reading package lists...
2022-03-19 18:07:28,851: INFO - + Building dependency tree...
2022-03-19 18:07:28,863: INFO - + Reading state information...
2022-03-19 18:07:30,208: INFO - + Correcting dependencies... Done
2022-03-19 18:07:31,052: INFO - + Calculating upgrade...
2022-03-19 18:07:32,224: INFO - + The following NEW packages will be installed:
2022-03-19 18:07:32,228: INFO - +   fontconfig hicolor-icon-theme imagemagick imagemagick-6-common
2022-03-19 18:07:32,233: INFO - +   imagemagick-6.q16 libarchive13 libc-client2007e libdatrie1 libde265-0
2022-03-19 18:07:32,238: INFO - +   libdjvulibre-text libdjvulibre21 libfftw3-double3 libgpgme11 libgraphite2-3
2022-03-19 18:07:32,242: INFO - +   libharfbuzz0b libheif1 libilmbase23 libjansson4 libjxr-tools libjxr0 libldb1
2022-03-19 18:07:32,247: INFO - +   liblqr-1-0 libmagickcore-6.q16-6 libmagickcore-6.q16-6-extra
2022-03-19 18:07:32,251: INFO - +   libmagickwand-6.q16-6 libnetpbm10 libopenexr23 libpango-1.0-0
2022-03-19 18:07:32,255: INFO - +   libpangocairo-1.0-0 libpangoft2-1.0-0 libpng12-0 libsmbclient libtdb1
2022-03-19 18:07:32,260: INFO - +   libtevent0 libthai-data libthai0 libwebpmux3 libwmf0.2-7 libx265-165 mlock
2022-03-19 18:07:32,264: INFO - +   netpbm php-apcu php-apcu-bc php-igbinary php-imagick php-redis php7.3-bcmath
2022-03-19 18:07:32,268: INFO - +   php7.3-bz2 php7.3-gmp php7.3-imap python-crypto python-gpg python-ldb
2022-03-19 18:07:32,273: INFO - +   python-samba python-talloc python-tdb samba-common samba-common-bin
2022-03-19 18:07:32,277: INFO - +   samba-dsdb-modules samba-libs smbclient ttf-dejavu-core
2022-03-19 18:07:32,298: INFO - + The following packages will be upgraded:
2022-03-19 18:07:32,308: INFO - +   bind9-host bind9utils dnsutils libbind9-161 libdns-export1104 libdns1104
2022-03-19 18:07:32,314: INFO - +   libirs161 libisc-export1100 libisc1100 libisccc161 libisccfg163 liblwres161
2022-03-19 18:07:32,325: INFO - +   libssl-dev libssl1.1 openssl rpi-eeprom
2022-03-19 18:07:32,874: INFO - + 16 upgraded, 62 newly installed, 0 to remove and 0 not upgraded.
2022-03-19 18:07:32,879: INFO - + Need to get 10.5 MB/30.2 MB of archives.
2022-03-19 18:07:32,883: INFO - + After this operation, 76.2 MB of additional disk space will be used.
2022-03-19 18:07:32,886: INFO - + Get:1 http://archive.raspberrypi.org/debian buster/main armhf libssl-dev armhf 1.1.1d-0+deb10u8+rpt1 [1,584 kB]
2022-03-19 18:07:33,176: INFO - + Get:2 http://archive.raspberrypi.org/debian buster/main armhf libssl1.1 armhf 1.1.1d-0+deb10u8+rpt1 [1,277 kB]
2022-03-19 18:07:33,346: INFO - + Get:3 http://archive.raspberrypi.org/debian buster/main armhf openssl armhf 1.1.1d-0+deb10u8+rpt1 [807 kB]
2022-03-19 18:07:33,406: INFO - + Get:4 http://archive.raspberrypi.org/debian buster/main armhf rpi-eeprom armhf 13.12-1~buster [1,847 kB]
2022-03-19 18:07:37,988: INFO - + Get:5 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf liblwres161 armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [247 kB]
2022-03-19 18:07:38,068: INFO - + Get:6 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf libisc1100 armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [422 kB]
2022-03-19 18:07:38,136: INFO - + Get:7 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf libdns1104 armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [1,075 kB]
2022-03-19 18:07:38,301: INFO - + Get:8 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf libisccc161 armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [234 kB]
2022-03-19 18:07:38,405: INFO - + Get:9 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf libisccfg163 armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [258 kB]
2022-03-19 18:07:38,568: INFO - + Get:10 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf libbind9-161 armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [244 kB]
2022-03-19 18:07:38,733: INFO - + Get:11 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf dnsutils armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [361 kB]
2022-03-19 18:07:38,899: INFO - + Get:12 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf bind9-host armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [269 kB]
2022-03-19 18:07:39,065: INFO - + Get:13 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf libirs161 armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [236 kB]
2022-03-19 18:07:39,268: INFO - + Get:14 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf bind9utils armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [422 kB]
2022-03-19 18:07:39,390: INFO - + Get:15 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf libisc-export1100 armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [360 kB]
2022-03-19 18:07:39,571: INFO - + Get:16 http://mirror.netzwerge.de/raspbian/raspbian buster/main armhf libdns-export1104 armhf 1:9.11.5.P4+dfsg-5.1+deb10u7 [872 kB]
2022-03-19 18:07:40,779: WARNING - Illegal instruction
2022-03-19 18:07:44,836: WARNING - Konnte für die folgenden Pakete das Upgrade nicht durchführen: bind9-host, bind9utils, dnsutils, libbind9-161, libdns-export1104, libdns1104, libirs161, libisc-export1100, libisc1100, libisccc161, libisccfg163, liblwres161, libssl-dev, libssl1.1, openssl, rpi-eeprom

Hi axeln,

Most welcome to the forums :slight_smile:

What a pity your apt got stuck. Raspberry Pi’s are too expensive for me, I only run Yunohost on Orange Pi’s (with Armbian). Raspbian got a few tweaks that I am not familiar with.

Having said that, I am surprised that your apt is complaining about Bind9. Which apps did you install? I just tried; bind9 is not a Cups-dependency.

I would login via SSH and try sudo apt remove bind9-host, and not continue right away, but check which packages get uninstalled with it. If there’s nothing interesting to be removed, continue, else abort. When you are not sure, post the output of the apt remove-command.

(Even so, it should not give an illegal instruction, but maybe that would work around the problem)


Hi wbk,

thanks for the prompt answer. Thanks for checking cups. If that is not likely, maybe I messed something up when installing within YunoHost. I did play around with synapse, for example.
Anyway, I tried you apt remove bind9 command and got this info about unmet dependencies.
apt keeps reminding me about --fix-broken install, but that is the command failing.

$ sudo apt remove bind9-host
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
avahi-daemon : Depends: bind9-host but it is not going to be installed or
dnsutils : Depends: bind9-host but it is not going to be installed or
nextcloud-ynh-deps : Depends: imagemagick
Depends: libmagickcore-6.q16-6-extra but it is not going to be installed
Depends: smbclient but it is not going to be installed
Depends: php7.3-bz2 but it is not going to be installed
Depends: php7.3-imap but it is not going to be installed
Depends: php7.3-gmp but it is not going to be installed
Depends: php7.3-apcu
Depends: php7.3-redis
Depends: php7.3-imagick
Depends: php7.3-igbinary
Depends: php7.3-bcmath but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

I have Matrix/Synapse installed as well, but no avahi-daemon. Avahi-daemon is one of the dependencies of Cups, I see, so that explains bind9.

There are some degrees of dependencies with apt, sometimes it’s a hard dependency, sometimes it’s a recommendation or a suggestion. There are options to have more or fewer packages installed, but I’m not well-versed enough with apt to give guidance here.

You could next try uninstalling cups, and then sudo apt autoremove to remove automatically installed dependencies of Cups. Then update and upgrade, perhaps sudo apt reinstall php7.3 to fix PHP for Nextcloud. When all is fixed, reinstall Cups (maybe check how to install only hard dependencies, not recommendations and suggestions)

Hi again!

Sorry, this took a while, but now I managed to clean apt up and get it working again. Although I tried to keep track of my actions, I cannot pinpoint the exact “solution” step, so I just list what I did, roughly.

a) apt remove cups
→ worked, but still apt reported problems (i.e. install --fix-broken install)

b) apt clean
→ no success

c) I noticed that one of the problems was a remainder of a failed nextcloud installation: apt remove nextcloud-ynh-deps
→ Illegal Instruction

d) “Nuclear” approach: ```
sudo dpkg --remove --force-remove-reinstreq nextcloud-ynh-deps

e) apt update
→ no more --fix-broken install – yay!

f) apt upgrade
→ Illegal Instruction – booo.

g) apt clean, apt purge, reboot

h) apt upgrade
→ working – yay!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.