Application redirects to YNH login when I am already logged in, then after login, application appears as blank white page

My YunoHost server

Hardware: Old laptop
YunoHost version: (stable)
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Whenever I try to open the rocketchat application it redirects me to the yunohost login (when I am already logged in). Then after logging in again: it redirects me to the actual access URL of of the application where it appears as a completely blank white page.

This issue just began one day, the application worked fine before when starting my server.

I believe this has to do with my browser or my PC trying to communicate with my server because the application works completely fine on my phone (and doesn’t ask me to login again when I try to access the app). I’m not sure if it’s the application itself at this point.

I tried rebooting yunohost, deleting my cookies, updating to the latest version of YNH and the latest version of rocketchat, I also tried changing the access URL of rocketchat. all to no avail.

the browser console doesn’t show anything of note besides this:

    createScript	@	VM861:14
    (anonymous)	@	VM861:17
    (anonymous)	@	VM861:18

(though this error shows up across any of my yunohost pages without issue)

the “Issues” tab shows this though I’m unsure as to the meaning or if it has anything to do with my issue:

Could you try running Rocketchat in a private/incognito browser window?

I’m curious about this domain.
Try a different browser or a different pc

Issue persists somehow even with private window.

Using a different browser works but I don’t want to switch browsers or have a separate browser open specifically for rocketchat…
I guess this is the solution for now though.

In that case a browser extension might interfere. If Firefox is your browser-of-choice, you could create an extra profile with no extensions active, see if it works. If it does, add extensions until you find which extension creates the problem, and see if it can be configured differently.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.