Application redirect reverse proxy & app tiers

My YunoHost server

Hardware: Old computer
YunoHost version: YunoHost (stable).
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain:
I got an extra Hard Drive, and I installed Gramps Web

Description of my issue

I’ve installed the Gramps Web application, which is accessible and functional on the local network from another computer by accessing port 5555 chosen at the time of deployment.

I’ve installed the YUnohost “redirect” application so that the application can be accessed from the outside, but when I try to access the application page, it’s empty and I get nothing.

Do you have any idea what’s causing the problem?

Thanks in advance for your help!

Mon serveur YunoHost

Matériel: Vieil ordinateur
Version de YunoHost: YunoHost (stable).
J’ai accès à mon serveur : En SSH | Par la webadmin | En direct avec un clavier/écran | …
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifications particulières sur votre instance ? : oui
Si oui, expliquer:
J’ai acheté un disque dur supplémentaire et j’ai installé Gramps Web.

Description du problème

J’ai installé l’application [Gramps Web] (Deploy with Docker - Gramps Web), qui est accessible et fonctionnelle sur le réseau local depuis un autre ordinateur en accédant au port 5555 choisi lors du déploiement.

J’ai installé l’application YUnohost “redirect” pour que l’application soit accessible depuis l’extérieur, mais lorsque j’essaie d’accéder à la page de l’application, elle est vide, je n’obtiens rien.

Avez-vous une idée de la cause du problème ?

Merci d’avance pour votre aide !

I use the reverse proxy app rather than redirect for this sort of thing. Maybe try that.

Hi !
Thank you for your message !

I just tried, but I only got the favicon and the right title of page (the one of Gramps Web) but nothing else … nothing in the page juste l’onglet du navigateur

Redirect and Reverse Proxy apps have the same feature. How have you set Redirect up, in which mode, with which address?

Can you also provide your browser logs?

If your issue is not related to an installation or upgrade process but instead is about an app failing load properly, ideally you can investigate with your browser console (opened with the F12 key): its Network tab can show you HTTP error codes (including the infamous 403, 404, 500…), and its Console can output errors too.

Screenshots are most welcome.

Hi, thank for your message ! Here some screenshot of my browser
The result of the page :

The error from the console :

I see that you have altered the screenshos, can you confirm the tab title is unaltered, “Gramps Web”? That would mean that something, at least, is loaded from the app. If you go to the Inspection tab of the browser tools, is there anything in there?

I only see errors related to the YunoHost user portal. Which brings me to one of my other questions:


I confirm that the title is “Gramps Web”, and the HTML (when I look the source code of the page) is the code of index.html file in the Gramps Web directory. So yes, it’s loading information from the app.

The only things hide in picture’s is the domain name for privacy concern. The application is installed on its own subdomain (and it’s the only app on this domain)

For the other question in this attempt, I use reverse proxy app with url : http://localhost:5555 which is the port on which the application is listening.

For the Static assets folder is /home/…/gramps where the app is installed and where is the index.html (and all other file of the app).

Notice that the app is running on Docker may be it has an influenced for the redirection.

Try and as alternatives. (two reasons, sometimes localhost resolves to ::1 and some apps do not like it, second reason is the ever confusing trailing slash in NGINX configs I never know if it should be there or not)

Can you check if it’s trying to directly load the asset files, without going through the proxy redirect? Maybe something in the app’s service logs can tell if requests are failing?

Hi !
For and it as the same result as http://localhost:5555.

Here is a picture of the site when I try to acces it in local network, I automaticly redirect to login page (and I can navigate correctly on the app), the css is correct…
I just got this error.

After this I thought a permission issue, so I gave 777 permission on the folder.

It didn’t work with reverse proxy (or may be there was cache idk)

After this I tried redirect app with reverse proxy first on http://localhost:5555
and the directory and now it work. but still with this permission on the folder… (permission not recurive)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.