App upgrade and install fails with internal error

,

My YunoHost server

Hardware: VPS at netcup
YunoHost version: 4.3.6.2 (stable)
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: modified ssh port and authentication via key as described in this wikipage

Description of my issue

Hi there,
I have been using YunoHost for quite some time now. Today, I wanted to upgrade one of my installed apps, but encountered the following error message:

"500" Internal Server Error

Trying to install a new app also yields the same error, and both operations don’t produce a log file.

Upon searching the forum, I found this relevant topic. I refrained from installing the suggested package libcurl3-gnutls=7.64.0-4+deb10u2 because it doesn’t seem to provide a permanent fix for the error. Sadly, the thread ended without a final conclusion, so I’d like to follow up with this thread. :sweat_smile:

Concerning the checks suggested by @Aleks :

Uhokay, can you try to run cd /tmp/ && git clone https://github.com/YunoHost-Apps/hextris_ynh ? (I’m just taking hextris as a random example)

Same thing with cd /tmp/ && curl https://app.yunohost.org/default/v2/apps.json (here also, taking apps.json as a random file to download)

They produce these results:

admin@###:~$ cd /tmp/ && git clone https://github.com/YunoHost-Apps/hextris_ynh
Cloning into 'hextris_ynh'...
fatal: unable to access 'https://github.com/YunoHost-Apps/hextris_ynh/': Failed sending HTTP2 data

admin@###:~$ cd /tmp/ && curl https://app.yunohost.org/default/v2/apps.json 
{"antifeatures": [{"description": {"en": "Tracks you and/or reports your activity to upstream maintainer or third parties, either without your permission or by default.", "fr": "Vous piste et/ou rapporte vos activit\u00e9s au mainteneur source ou \u00e0 des tiers, sans votre permission ou par d\u00e9faut."}, "icon": "user-secret", "id": "tracking",
... (output shortend)

Any kind of help or tip is kindly appreciated.
Best regards from Germany! :slightly_smiling_face:

This thread on stackoverflow seems to suggests that the “Failed sending HTTP2 data” from git clone is related to libcurl3-gnutls:

1 Like

Thanks for the fast reply and this pointer!
The suggested solution from stackoverflow worked for me.
After downgrading libcurl3-gnutls via sudo apt reinstall libcurl3-gnutls/buster upgrades and installs work again.
As suggested on stackoverflow I will hold back the package for the time being via sudo apt-mark hold libcurl3-gnutls.

Thanks again for your fast help and great efforts! :+1:t3:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.