App installation blocked by dovecot issue:

Hello :slight_smile:

When trying to install an app, install fails because of an issue with doveadm. Trying the command alone raise the same result:

doveadm -f flow quota get -u MyUser
doveadm(root): Fatal: Unknown command ‘quota’, but plugin quota exists. Try to set mail_plugins=quota

I tried to remove and re-install dovecot, no change.

Do you know how I can fix this issue ? Thanks :slight_smile:

Which YunoHost version is used ?

For the moment I think you can work around by stopping dovecot

Note: if dovecot is stopped, you won’t be able to download your email.

Which application have you tried to install? We need this information to be able to reproduce this bug.

Thanks for the report :heart:

I used 2.4, now updated to 2.5, no change.

Ok, I’ll test that :slight_smile:

Oh, and on which system? Are you using armbian?

Are you on an arm board (rpi, olinuxino, internet cubre/Brique Internet, cubibox …) ?

Raspberry Pi 3
I tried with owncloud.

What is the result of this command

sudo doveadm -f flow quota get -u USER

Replace USER by a yunohost user of your server

This one:

Which app did you want to install ?

I think your quota plugin is not setup due to an arm specificity (may be because recommends package are not set up)

Try to run grep mail_plugins /etc/dovecot/dovecot.conf. You should get this:

root@yunohost:/home/vagrant# grep mail_plugins /etc/dovecot/dovecot.conf 
mail_plugins = $mail_plugins quota
  mail_plugins = $mail_plugins imap_quota antispam
  mail_plugins = quota sieve

The result is empty :confused:

can you install “dovecot-sieve” ?
[sudo apt install dovecot-sieve]

Then, give the result of "grep mail_plugins /etc/dovecot/dovecot.conf ".

strange !
May be you or an app change the dovecot conf ?

If you want watch differences:

yunohost service regen-conf --with-diff dovecot

If you want restore the dovecot conf:

yunohost service regen-conf --force dovecot

Already done before those tests.

I just did it, no errors now. Let’s try again installing owncloud :slight_smile:

It works :slight_smile:

Thanks for your help ! :slight_smile:

(now let’s tackle let’s encrypt removing issues… ^^)