App autologin does not work after moving SSO portal to subdomain

, ,

Hey. I have a general question (before going into hardware details etc.):

The Situation is:
Main domain was example.com, apps were on subdomains (e.g. cloud.example.com). LDAP worked, SSO as well (I was already logged into an app, when clicking on its tile in the portal).
Now I moved the main domain (and SSO portal) to portal.example.com while apps still being on subdomains (e.g. cloud.portal.com). LDAP still works, but now I have to manually log in at cloud.example.com when I click on the tile.

I think this has something to do with this topic:

In your case, I expect Yunohost’s main domain to be (for example) yunohost.grubhska.fr, with Nextcloud on nextcloud.grubhska.fr ? […]

Question:
Is it possible to activate SSO for apps on a sibling URL of the portal? What would I need to do in order to do so? The linked topic does not really answer this…

What I already tried:
Thought this could solve the issue, but it didn’t:
sudo yunohost app ssowatconf

Thank you so much in advance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.