API not Responding

I cannot get into my Yunohost dashboard anymore. When I enter my password, I get “API not responding.”

I’ve tried various suggestions that I found here on the forum, but I can’t get it to run. The server is working though, I just can’t access it from the dashboard.

I’m using an RPi in my basement.

Any help or ideas would be appreciated.

Uh, if you are able to connect through ssh, you should try restarting the Yunohost API with :

systemctl restart yunohost-api

(not sure why it got down though)

That did not work … it seems to login, but then ‘API not responding’ comes up. I also tried “service yunohost-api restart”

I’m also not sure why it went down. We have not had any power failures or anything that might corrupt it.

What else can I do?

Hm so what does “systemctl status yunohost-api” tells ? Is there an error message ?

This is what it shows:


And now I notice that Seafile is also not working. I get 502 Bad Gateway nginx.

Hoping to get some small help.

I don’t know enough about Linux to do much without destroying everything … Don’t mind learning though.

I got it working again … I have NO clue how. lol.

The last thing I did was install a new app from the command line and then I removed it … and suddenly my API was back.

I’m now updating and backing up and making sure everything is still working. Weird.

yeah i have similar problem, but I am using Vagrant and i and recieved this api error after the post-installation.

vagrant@test873424:~$ systemctl restart yunohost-api
Failed to restart yunohost-api.service: The name org.freedesktop.PolicyKit1 was not provided by any .service files
See system logs and 'systemctl status yunohost-api.service' for details.
vagrant@test873424:~$ systemctl status yunohost-api.service
 yunohost-api.service - YunoHost API Server
   Loaded: loaded (/lib/systemd/system/yunohost-api.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2018-10-14 15:39:34 GMT; 19min ago
 Main PID: 568 (yunohost-api)
   CGroup: /system.slice/yunohost-api.service
           └─568 /usr/bin/python /usr/bin/yunohost-api

OS: Kali Linux (KDE)
Yunohost version: 3.2.2 (not sure)

Nevermind I kinda fixed it. Just a simple restart has done the work