[Apache Guacamole] Can't set up any connection

My YunoHost server

Hardware: Intel NUC
YunoHost version:
I have access to my server : Yes, by all means
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : I’m using a VPN to open it safely

Description of my issue

I’m trying to set up connections with Apache Guacamole. Whatever I try, VNC, RDP, SSH, neither of them work. It could be me, but after trying every type of connection and checked the parameters, I went to check the logs from Yunohost too see that message :

avril 24 22:40:42 guacamole-tomcat9[744]: 22:40:42.873 [http-nio-8080-exec-7] ERROR o.a.g.w.GuacamoleWebSocketTunnelEndpoint - Creation of WebSocket tunnel to guacd failed: java.net.ConnectException: Connexion refusée (Connection refused)
avril 24 22:40:42 guacamole-tomcat9[744]: 22:40:42.936 [http-nio-8080-exec-10] ERROR o.a.g.s.GuacamoleHTTPTunnelServlet - HTTP tunnel request failed: java.net.ConnectException: Connexion refusée (Connection refused)

And this what is showed on screen :

Full logs (Look at the end) : hastebin

I really don’t know what it is saying :sweat_smile:
Have a great day !

After looking around the Github, I found someone with the same issue, partially solved : WebSocket tunnel to guacd failed: Connection refused · Issue #19 · YunoHost-Apps/guacamole_ynh · GitHub

I’m gonna try that tomorrow.

Replying so I can follow if this gets a solution, as I’m having the same issue

That github fix is working for SSH !

Still nothing with VNC, and didn’t tried with RDP for now.

This is the result with VNC : hastebin

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.