Ancien domaine en .ynh toujours présent?

Mon serveur YunoHost

Matériel: Raspberry Pi à la maison / Brique Internet avec VPN /
Version de YunoHost: 4.1.7.1
J’ai accès à mon serveur : En SSH | Par la webadmin | En direct avec un clavier/écran | …
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Yunohost cherche-t-il encore un nom de domaine modifié ?

Bonjour,
il y a à peu près un an, j’ai fait une migration de mon serveur sur un OrangePi vers un raspberry4, pour cela, j’avais d’abord installé sur le raspberry un serveur avec un nom de domaine du style nom_domaine.ynh, puis une fois tout en place, j’ai du demandé à le supprimer pour le changer avec nom_domaine.fr… Étrangement, je vois dans les Journaux ce message récent (ces messages, 14 messages entre “il y a 21 heures” et “il y a 16 heures”) :

Mettre à jour l’adresse IP associée à votre sous-domaine YunoHost ‘rodinux.ynh.fr

avec ce log /var/log/yunohost/categories/operation/20210220-061604-dyndns_update-nom_de_domaine.ynh.fr.log

2021-02-20 07:16:04,861: INFO - Updated needed, going on...
2021-02-20 07:16:04,866: DEBUG - Reusing IPv4 from cache: XX.XXX.XXX.XXX
2021-02-20 07:16:04,867: DEBUG - Reusing IPv6 from cache: 2aXX:XXX:XXXX:XXXX::X
2021-02-20 07:16:04,875: DEBUG - Now pushing new conf to DynDNS host...
2021-02-20 07:16:05,474: SUCCESS - Updated your IP on DynDNS

Alors, est-ce que j’ai oublié quelque chose en changeant le nom de domaine à l’époque ?

À l’époque, j’avais fait ainsi:

# yunohost tools main-domain -n nom_domaine.fr

Une commande à propos de dyndns:

$ ls /etc/yunohost/dyndns
Knom_domaine.ynh.fr.+165+20010.key	Knom_domaine.ynh.fr.+165+20010.private  zone

Autre chose, j’utilise un vpn…

Par contre, je découvre un soucis avec vpn_client et ma configuration pour le vpn, le serveur n’a pas pris la bonne adresse ipv6 du vpn d’ilysse pour le reverse dns qui devrait finir par :42, là il a pris une adresse qui finit par :2. Je ne sais pas si c’est mon .cube qui n’est pas bien fichu ou juste besoin d’un redémarrage…

Tu peux faire un yunohost dyndns removecron, ça devrait supprimer la tâche automatique de mise à jour du ynh.fr

C’est parti après un redémarrage… Je pense que le soucis venait aussi de l’IPv6 qui n’était pas en accord avec le reverse dns. Après un échange avec Ilysse, j’ai peut-être trouver la parade, voici leur réponse (ça peut aider):

C’est un problème assez classique avec Yunoshot. Visiblement y a un truc hardcodé dans l’appli client VPN qui prend la ::42
Sauf que sur le VPN Illyse on pousse déjà automatiquement une IPv6 (au même titre que ce qui est fait en IPv4)

Du coup le serveur yunohost se retrouve avec deux IPv6 (la ::42 et la ::2). Les deux sont joignables, fonctionnent. Ce n’est pas vraiment un soucis.
Pour les flux sortants, je ne sais pas si c’est la ::42 ou la ::2 qui est utilisée. Pour d’autre personne on a défini le reverse DNS à la fois sur la ::42 et sur la ::2, comme ça le serveur peut utiliser les deux indifféremment en sortie pour envoyer du mail.

Tu peux essayer 2 choses:

  • comme tu le propose, dans COIN, mettre la ::42 comme IP poussée par le serveur Illyse.
  • ou bien, dans COIN laisser le champ IPv6 complètement vide. Le /56 devrait toujours est bien routé dans ton tunnel, mais le serveur ne poussera pas la ::2. Et yunohost prendra la ::42 comme a son habitude.

Bon, après un test, ça n’a pas bien marché pour moi…
Si j’enlève l’adresse IPv6 sur la première ligne, je n’ai plus du tout l’adresse ipv6 du vpn, mais celle de la box il me semble…
Si je je met celle qui finie en ::42… ça fini par marcher après quelques essais…